View Single Post
Old 12-08-08, 01:56 PM   #1
ares01590
Registered User
 
Join Date: Dec 2008
Posts: 2
Default ConnectedMonitor hangs under mythbuntu 8.10 with nvidia driver version 177.80

Please help! I've been chasing this for a couple of days.

Title gives most of the information. I just upgraded to mythbuntu 8.10 from mythbuntu 8.04. Nvidia driver version therefore went from 169.?? to 177.80. Under 169.?? ConnectedMonitor worked fine, but I want to try and use the HDMI audio, so I need a newer driver.

My machine is a MSI Media Live with 6150LE integrated graphics. I am using HDMI out, and have nothing attached to the svideo or vga outs. Since I have other devices in my home theater it is important to have the Media Live boot and think the HDMI is connected no matter what (if anything) is being watched at the time. Since the upgrade the machine locks up hard on boot if the TV/receiver is not "watching" the HDMI output of the box. It boots perfectly if I am "watching" the boot process. If I comment out the ConnectedMonitor line it boots fine, but will choose CRT instead of DFP for output -- which is useless in my case.

Note that the Xorg.0.log is 0 bytes after the hang. I get no errors/warnings in any logfile I can find. There is no signal to the TV if I switch to the HDMI input after boot has hung.

here's my xorg.conf:

Code:
Section "Screen"
	Identifier 	"Screen0"
	Monitor    	"Monitor0"
	Device     	"Videocard0"
	SubSection "Display"
		Modes    "jvc720p"
	EndSubSection
#	Option		"AddARGBGLXVisuals"	"True"
	DefaultDepth     24
EndSection

Section "Device"
	Identifier	"Videocard0"
	Driver		"nvidia"
	Vendorname	"nVidia Corporation"
	Boardname	"C51 [GeForce 6150 LE]"
	Busid		"PCI:0:5:0"
	Option		"NoLogo" "True"
	Option		"DPI" "100 x 100"
        Option		"IgnoreDisplayDevices" "CRT,TV"
	Option		"ConnectedMonitor" "DFP"
	Option		"UseDisplayDevice" "DFP"
	Option		"UseEDID" "false"
	Option		"ExactModeTimingsDVI" "true"
	Option		"ModeValidation" "NoVesaModes,NoXServerModes,NoHorizSyncCheck,NoVertRefreshCheck,AllowNon60HzDFPModes,NoDFPNativeResolutionCheck,NoVirtualSizeCheck"
	Option		"UseEvents" "true"
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Screen0" 
	Option		"StandbyTime" "0"
	Option		"SuspendTime" "0"
	Option		"OffTime"     "0"
EndSection

Section "Module"
	Load		"glx"
EndSection

Section "Monitor"
	Identifier	"Monitor0"
	HorizSync	15.0 - 46.0
	VertRefresh	59.0 - 61.0
	ModeLine	"jvc720p" 74.250 1280 1390 1430 1650 720 725 730 750 +hsync +vsync
#	Option		"DPMS" "false"
EndSection

Section "Extensions"
	Option		"Composite" "Enable"
EndSection
ares01590 is offline   Reply With Quote