View Single Post
Old 12-29-08, 01:35 PM   #1
schomin
Registered User
 
Join Date: Dec 2008
Posts: 23
Default problems with compiz and multiple cards

Ok so i have two 8800gt's (not in SLI) with a monitor connected to each. I have xinerama enable on the monitors so i can have a single desktop spanning across two GPU's and two displays. I can't seem to get compiz to work though i'm not sure if xinerama supports it but i've herd people have gotten compiz to work with xinerama.

I guess my question is what kind of options do i have and is there a better setup than what i have now? because i want the two gpu's and i want compiz.

Also i'm getting some smearing between monitors i'm guessing this is because of the seperate gpu's and xinerama.

I'm using 180.12 i think it is

heres my xorg.conf:

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Sun Dec 14 20:59:16 PST 2008

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder58)  Sun Dec 14 20:59:58 PST 2008

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" 1920 150
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "1"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbLayout" "us"
    Option         "XkbModel" "pc105"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync       27.0 - 81.0
    VertRefresh     50.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GT"
    BusID          "PCI:1:0:0"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GT"
    BusID          "PCI:3:0:0"
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +0+0"
# Removed Option "metamodes" "DFP-0: nvidia-auto-select +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AllowGLXWithComposite" "True"
    Option         "RenderAccel" "true"
    Option         "AddARGBGLXVisuals" "True"
    Option         "DRI" "True"
    Option         "SLI" "off"
    Option         "MultiGPU" "off"
    Option         "TwinView" "1"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "CursorShadow" "true"
    Option         "AddARGBVisuals" "True"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +0+0"
# Removed Option "metamodes" "DFP-1: nvidia-auto-select +0+0"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "AllowGLXWithComposite" "True"
    Option         "RenderAccel" "true"
    Option         "AddARGBGLXVisuals" "True"
    Option         "DRI" "True"
    Option         "SLI" "off"
    Option         "MultiGPU" "off"
    Option         "TwinView" "1"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "CursorShadow" "true"
    Option         "AddARGBVisuals" "True"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "RENDER" "true"
    Option         "Composite" "Enable"
EndSection
schomin is offline   Reply With Quote