View Single Post
Old 09-08-03, 04:07 AM   #2
mesters
Registered User
 
Join Date: Aug 2003
Location: Germany
Posts: 9
Default

Yes, I have seen that one several times.

Delete all stuff that has to do with modes-lines and have the software work out the mode that can work with your dual-setup. In my case I had the frequencies to high and just not enough memory for running both monitors (only 128mb....).

Just copy the lines below into your /etc/X11/XF86Config file.

Here are the relevant lines from my twinview setup:

Section "Monitor"
Identifier "Monitor[1]"
ModelName "FP1702"
VendorName "DELL"
HorizSync 31-80
VertRefresh 56-65
EndSection

Section "Monitor"
Identifier "Monitor[0]"
ModelName "P1130"
VendorName "DELL"
HorizSync 30-130
VertRefresh 80-170
EndSection

#Section "Modes"
# Identifier "Modes[0]"
#EndSection

#Section "Modes"
# Identifier "Modes[1]"
#EndSection

Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1280x1024"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "Quadro4 900XGL"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Option "Dac8Bit"
Option "NvAGP" "3"
Option "Stereo" "3"
Option "Rotate" "off"
Option "ConnectedMonitor" ""
Option "NoTwinViewXineramaInfo"
Option "TwinView" "on"
Option "MetaModes" "1280x1024 , 1280x1024"
Option "TwinViewOrientation" "Rightof"
Option "SecondMonitorHorizSync" "31-80"
Option "SecondMonitorVertRefresh" "48-65"
Screen 0
VendorName "NVidia"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen 0 "Screen[0]" 0 0
EndSection
mesters is offline   Reply With Quote