View Single Post
Old 01-04-09, 07:22 AM   #3
Rudd-O
Registered User
 
Join Date: Dec 2008
Posts: 21
Default Re: screen corruption and possible system crash

Wow, interesting. I have the EXACT SAME PROBLEM on Linux 64bit. Check the NVIDIA Linux forum for "corruption with driver 180.xx", TONS of other people have this problem.

Quote:
Originally Posted by HenryHu View Post
Recently, started from version 177.xx or 180.xx, I experienced such thing.
At first, screen started to flash. Then if I try to switch to console by repeatedly press Ctrl+Alt+F1, most of the time I would success after some tries.
If I do nothing, the system would lock up after some time, and occasionally the system would restart, possibly due to kernel panic.
When I switch back from console back to X after the flash, the screen corrupted. I have to restart compiz or switch to other WMs to get back the normal screen.
There are NVRM messages:
NVRM: Xid (0001:00): 13, 0001 00000000 0000502d 00000860 001c1c1c 00000100
NVRM: Xid (0001:00): 13, 0003 00000000 00008297 00001408 00000001 00000040
NVRM: Xid (0001:00): 13, 0001 00000000 0000502d 000008dc 00000000 00000100
NVRM: Xid (0001:00): 13, 0001 00000000 00005097 00000680 000a0009 00000100
NVRM: Xid (0001:00): 13, 0001 00000000 00005039 00000328 00000000 00000002
NVRM: Xid (0001:00): 13, 0001 00000000 00005039 00000328 00000000 00000002
NVRM: Xid (0001:00): 13, 0001 00000000 00005039 00000328 00000000 00000002
NVRM: Xid (0001:00): 13, 0001 00000000 00005039 00000328 00000000 00000002

I've also got some screenshots after I switch back to X.
The programs running are fqterm ( which uses Qt4 ), compiz, avant-window-navigator, firefox, urxvt. I think this problem is related to Qt4 or compiz.
I've seen similar messages on the linux board, so I think that it's not the problem about my card.

I've seen something strange in the screenshots. I've not started compiz benchmark today, but it showed up...
Rudd-O is offline   Reply With Quote