View Single Post
Old 09-09-03, 06:19 AM   #2
AndyNicholson
Registered User
 
Join Date: Sep 2003
Location: UK
Posts: 8
Default

Congratulations mangus, and thanks for posting it.

In my news searches I missed APIC as a possible solution. I must have read APCI every time I hit it.

Interestingly I already have APIC disabled in my BIOS. I must have disabled it two years ago when getting the system going for the first time - I don't recall why. The kernel seems to ignore the BIOS. Looking back at archived syslogs it was doing this long before I started getting the X freeze problem. Some non-consecutive lines from my syslog:
Sep 8 18:34:53 domus kernel: Local APIC disabled by BIOS -- reenabling.
Sep 8 18:34:53 domus kernel: Found and enabled local APIC!
Sep 8 18:34:53 domus kernel: Using local APIC timer interrupts.
Sep 8 18:34:53 domus kernel: calibrating APIC timer ...
Sep 8 18:34:53 domus kernel: PCI: Disabling Via external APIC routing


I'll try your APIC solution next if (once) my current attempt has failed.
I'm currently disabling apm and acpi via lilo boot options: apm=off acpi=off. I probably have to wait a week or so before I know this hasn't fixed things for me.
There are lots of solutions in the news groups that have worked for some people but not others. APIC looks very promising.
AndyNicholson is offline   Reply With Quote