View Single Post
Old 01-11-09, 01:32 PM   #1
younan1
Registered User
 
Join Date: Aug 2008
Posts: 10
Default Failed to initialize the Nvidia Kernel Module!

I have the geforce 7600 and I'm using Ubuntu 8.10. I had the 177 driver installed with no problems and decided to try out the new 180.22 driver.
I switched to another tty and stopped GDM. Then I ran the installer after giving it 777 permissions:
Code:
sudo sh ./NVIDIA-Linux-x86-180.22-pkg1.run
Installation looked fine, just like the others i've done, but after the reboot I got this message:
Code:
Failed to initialize the Nvidia Kernel Module!
Please ensure that there is a supported Nvidia GPU in this system and that the Nvidia device files have been created properly.
Please consult with the Nvidia README for details
***Aborting***
Screens found, but none have a usable configuration.
After this I can log in ok, but I don't believe I am running the nvidia driver.
Running glxinfo gives this:
Code:
 glxinfo
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
2 GLXFBConfigs:
   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
Segmentation fault
But when I run lsmod:
Code:
 lsmod | grep nvidia
nvidia               6909268  0 
i2c_core               31892  2 nvidia,i2c_nforce2
nvidia_agp             14492  1 
agpgart                42184  2 nvidia,nvidia_agp
I tried to follow the instructions in this sticky, http://www.nvnews.net/vbulletin/showthread.php?t=46678, but when I execute
Code:
startx -- -logverbose 6
I get the same error and it fails to load. I've attached the /var/log/Xorg.0.log file.
So I proceeded with the nvidia-bug-report anyway and attached that log along with the installer log.
Here is my xorg.conf, if that helps
Code:
Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Configured Monitor"
EndSection

Section "Device"
    Identifier     "Configured Video Device"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Configured Video Device"
    Monitor        "Configured Monitor"
    DefaultDepth    24
    Option         "NoLogo" "True"
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection
There was some promising stuff on this thread:
http://www.nvnews.net/vbulletin/showthread.php?t=38398
Particularly the post by jmcqueen:
Quote:
/sbin/modprobe nvidia
cd /dev
cp -a nvidia* /etc/udev/devices
chown root.root /etc/udev/devices/nvidia*
logout
exit
But I believe these device files are not in the same place for my distro and I wasn't sure how to proceed. I searched for 'devices' in /etc and found none...

Someone please help! There is another thread on here talking about how awesome this new driver is, I want it!
Attached Files
File Type: log nvidia-installer.log (44.6 KB, 101 views)
File Type: log Xorg.0.log (40.9 KB, 110 views)
File Type: bz2 nvidia-bug-report.log.tar.bz2 (34.8 KB, 88 views)
younan1 is offline   Reply With Quote