View Single Post
Old 09-10-03, 03:59 AM   #1
ubmat
Registered User
 
Join Date: Sep 2003
Posts: 2
Question GeForce FX 5200 tv-out black and white

I haven't managed to get my tv-out working in colours. Pardon my language, i'm not native english speaker.

I have tried two different graphic cards, both with geforce fx5200 chip and svideo tv-out.
It seems that my svideo cable is ok, it is new and after running these problems, I measured it with multimeter. Also, I have tried two different televisions, smaller supports only PAL and the better one both PAL and NTSC.

Some software versions, if they're relevant:
NVIDIA-Linux-x86-1.0-4496
Debian woody with kernel 2.4.22
XFree86 4.0.1

Video bios (second card) 04.34.20.18.00,
I already got rid of the first one, it was MSI

About XF86Config-4, have tried tweaking
Option "TVStandard" to "PAL-B" and "NTSC-M", tried also without this option.
No difference.
Tried vertrefresh 50, 53 and 60, no difference.
Tried TVOutFormat SVIDEO and COMPOSITE, the first card had also composite apadtor included.

Current configs follow::

Section "Device"
Identifier "nvidiatwin"
Driver "nvidia"
Option "TwinView"
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorVertRefresh" "60"
Option "MetaModes" "1280x960, NULL; 1152x864, NULL; 1024x768, NULL; 800x600, 800x600; 720x576, 720x576; 640x480, 640x480"
Option "ConnectedMonitor" "CRT, TV"
Option "TwinViewOrientation" "Clone"
Option "NoDPMS"
EndSection

Section "Monitor"
Identifier "panasonic"
HorizSync 30-50
VertRefresh 60
Option "TVStandard" "PAL-B"
Option "ConnectedMonitor" "TV"

Option "TVOutFormat" "SVIDEO"
Option "DPMS" "false"
EndSection


That's it, result is that tv-out remains black&white.

Give me a clue, thanks!
ubmat is offline   Reply With Quote