View Single Post
Old 09-10-03, 11:18 AM   #8
xiphmont
Registered User
 
Join Date: Jul 2003
Location: Somerville, MA
Posts: 17
Send a message via AIM to xiphmont
Default

Quote:
Originally posted by vvarder
Hi all,

I had the same problem with the sound stutter (I have a Athlon XP 1700 with a nVidia GeForce 2 PCI and a Soundblaster PCI128). I took the mtrr out -- not wanting to recompile the kernel again, I just issued the command (from the mtrr linux kernel documentation):
echo "disable=#" >| /proc/mtrr
For each of the registers and I no longer recieved any stutter. However, I agree that this seems a band-aid way to fix it, and it does kill performance (although my few test opengl apps still had high frame-rates). For me, the sound was like listening to a radio station that was out of range with mtrr. Is there a "compromise" way to have at least partial mtrr support without killing sound performance? Maybe using another register to burst the sound across the pci bus? Or maybe just reducing the size of the register entries? Any thoughts would be appreciated.

-Josh
Oh, BTW! You don't need to kill *all* mtrr; just the one range used by the video card. Look up the memory range via lspci -v, then disable the one register associated with that range.

That avoids disabling write-combine for things that need it, like the bridges and system controller.

Monty
xiphmont is offline   Reply With Quote