View Single Post
Old 01-17-09, 09:57 AM   #15
Felix.K
Registered User
 
Join Date: Jan 2009
Posts: 17
Default Re: XEN - NVIDIA - STEP BY STEP

Firstly, I want to thank muchologo for his tutorial, because it was the only solution I found that made the nvidia driver working in my XEN Dom0 Kernel. But I also discovered the problem that I am no longer able to see (or switch back to) any TTYs after I startet X.

My Hardware is an Intel QuadCore @ 2.8 GHz, 4 GB DDR2 RAM and a GeForce 8800 GT.
I used the newest official XEN Hypervisor (3.3.1) and the newest Dom0 Kernel that is published by XenSource (2.6.27.5). My NVIDIA driver is 180.22 and everything is 64-Bit.

Secondly, I have done some further investigations on this problem:
The problem happens, when an X server starts with the nvidia driver, but not when the module is loaded without any X system. So it only occurs after starting X.
It disallows me to switch back to any TTY on the screen, no matter how I try to do it (stopping X, Ctrl + Alt + F1, rebooting, executing chvt 1). But the TTYs are still running without problems (except that I can't see anything on the screen), because I can still type in commands and they are actually executed. I can also switch back to X.
In addition, there is no problem with running multiple X servers and switching between them. I can even stop the second one and return to the first without problems by pressing Ctrl + Alt + F7. But still there are no normal TTYs visible after I startet the first X.
After that, I tried accessing the system with a serial console and without any normal TTYs at all. That worked fine and the serial console is still running without any problems after I started X.
Now I tried to use serial and normal TTYs and removed the NVIDIA driver module after stopping X. My displays remained black and were in power saving mode (probably this is important: The displays are actually disabled).
Finally, I startet a new getty after I shut down X and removed the kernel module, but I couldn't see the new TTY either (but I could log in and execute commands without seeing anything).

I am now not able to test it again with acpi=off or pci=noacpi kernel parameters, because my HDDs are no longer detected when I use those options. Is there a way to specify a noacpi option only to the nvidia driver module?
Felix.K is offline   Reply With Quote