Thread: Deadlock on 7.1
View Single Post
Old 01-19-09, 04:06 AM   #5
h1web
Registered User
 
Join Date: Jan 2009
Posts: 3
Default Re: Deadlock on 7.1

Quote:
Originally Posted by sillium View Post
Hi,

i experienced similar problems on my box:
Intel X38, 4gig ram, 2x 8600GT

The nvidia drivers refused to work, they eventually locked up my box on starting X.

A possible solution for this seems to remove some RAM (to get below/equal to the 3gig limit on i386) or some other trick i found somewhere on the freebsd mailing list archives:

Put this line in /boot/loader.conf:

machdep.disable_mtrrs=1

I wonder why this is nowhere mentioned in the documentation/readme as it made everything work nicely even with 8gig of ram (despite of not having amd64..)

Hope this is helpful for you.
Oh wow, indeed it is! Thanks a lot!
Setting machdep.disable_mtrrs to 1 fixed the problem. This has already killed my MBR+partition table due to data loss and now you finally gave me the solution. Thanks!

I agree with you, this should definitely be added to the documentation or someone should at least sticky it.
h1web is offline   Reply With Quote