View Single Post
Old 07-29-02, 11:04 PM   #8
ghost_o
Guest
 
Posts: n/a
Default

Quote:
Originally posted by Petersen
Hi,

I don't have any problem with dpms! Using a geforce2 mx, the latest nvidia drivers and running xfree 4.02.

What does "xset q" tell you?
especially these lines:

Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 420 cycle: 600

I found out that kde likes to set the screen saver timeout to 0 (zero), which disables dpms for me (and which is the same as setting "xset s 0").

If I want to have dpms working under kde, I have to
a) enable dpms in the control centre of kde
plus
b) launch "xset s 420" (or something like that) via the .xinitrc

A "zero" value (see above) disables dpms, which means that when entering the dpms state the screen starts flashing and flashing in a very distorted way.

Maybe you could check this?


Regards
Petersen
If I leave my configuration 'identical' other than use the "nvidia" versus "nv" driver in my xfree file, DPMS OFF mode breaks. Standby still works as expected, just OFF quits working and it sends my monitor a sync and refresh that it cannot understand. Quickly switching back to "nv" driver, restarting x-session and all works like it should again. I do not even have xscreensaver installed. I am running Gnome2.0 these next few days to see if I like it better (only been running Linux with a monitor for about 3 months now) than KDE, and it behaves exactly as KDE, so it is definately between the xserver and the nvidia driver somewhere. I have tried literally 30 different combinations of driver, agpsetting, where in the XF86config-4 file to place settings, where to put stuff in the .xinitrc files for startx.. My conclusion - on geforce256 DDR, the NVdriver is broke. There was someone else with exact behavior as me that even went to the trouble to get in touch with nVidia to no avail, so I have pretty much given up after wasting 8-10 hours trying to figure it out.

Oh well, like I said, I do nothing that the speed increase of OpenGL would really help anyway, so I am not that bummed out, I just hate to think I am not getting all I can out of the system you know
  Reply With Quote