Thread: mplayer vdpau
View Single Post
Old 01-27-09, 01:40 PM   #639
ttabbal
Registered User
 
Join Date: Dec 2008
Posts: 14
Default Re: mplayer vdpau

Quote:
Originally Posted by jyavenard View Post
Hi

I thought VDPAU VC-1 decoding supports was only found on 9300/9400 kind of chipset?

An Asus M3n78-em (GeForce 8300 IGP) reports the following capabilities:

Decoder capabilities:

name level macbs width height

------------------------------------
MPEG1 0 8191 2032 2032
MPEG2_SIMPLE 3 8191 2032 2032
MPEG2_MAIN 3 8191 2032 2032
H264_MAIN 41 8191 2032 2032
H264_HIGH 41 8191 2032 2032
VC1_SIMPLE 1 8191 2032 2032
VC1_MAIN 2 8191 2032 2032
VC1_ADVANCED 4 8191 2032 2032

So what's the go ?

Another datapoint, from an M3N78-VM (GF8200).

Code:
Decoder capabilities:

name          level macbs width height
------------------------------------
MPEG1             0     2  4096  4096
MPEG2_SIMPLE      3     2  4096  4096
MPEG2_MAIN        3     2  4096  4096
H264_MAIN        41    16  4096  4096
H264_HIGH        41    16  4096  4096
VC1_SIMPLE        1     2  4096  4096
VC1_MAIN          2     2  4096  4096
VC1_ADVANCED      4     2  4096  4096
Not only does it report, I download the VC-1 sample from the first page of this thread, and mplayer says it's playing it. I'm remote using SSH right now, so I can't verify for sure. I'll edit this post tonight with the visual results. Interesting anyway. I expected mplayer would error out on me, it proceeds to try to play the video. The WMA audio codecs aren't compiled in, so it does give me a "Audio: no sound". But that's not a big deal.

Code:
VDec: vo config request - 1280 x 720 (preferred colorspace: VC1 ADVANCED VDPAU acceleration)
VDec: using VC1 ADVANCED VDPAU acceleration as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [vdpau] 1280x720 => 1280x720 VC1 ADVANCED VDPAU acceleration
ttabbal is offline   Reply With Quote