Thread: mplayer vdpau
View Single Post
Old 01-27-09, 04:26 PM   #645
The_Rebel
Registered User
 
Join Date: Jan 2009
Posts: 9
Default Re: mplayer vdpau

Quote:
Originally Posted by Stephen Warren View Post
On the screen with compiz, you're either just getting lucky and no seeing the tearing, or compiz itself is syncing to VBLANK when it renders (or perhaps you've turned that on in the OpenGL settings).

On the other screen, you have the composite extension enabled, so it uses the blit-based presentation queue implementation, which doesn't sync to VBLANK, and so tears.
I am using VBLANK syncing with opengl, but if i run compiz on both screens (separate X sessions) i get tearing on the secondary display.

Is there a way to disable compositing on a per screen basis?
The_Rebel is offline   Reply With Quote