View Single Post
Old 02-01-09, 06:49 AM   #1
rhurlin
FreeBSD in Science
 
rhurlin's Avatar
 
Join Date: Jan 2007
Location: Northeim, Germany
Posts: 22
Default x11/nvidia-driver does not compile on current

I asked this before on ports@freebsd.org but got no answer. Perhaps here someone could help.

On newest FreeBSD 8.0-CURRENT with up to date Xorg I am not able to compile x11/nvidia-driver on different machines any more. This is what I get:

-------------------------------------------------------------
/usr/ports/x11/nvidia-driver#make
===> Vulnerability check disabled, database not found
===> Found saved configuration for nvidia-driver-177.80
===> Extracting for nvidia-driver-177.80
=> MD5 Checksum OK for NVIDIA-FreeBSD-x86-177.80.tar.gz.
=> SHA256 Checksum OK for NVIDIA-FreeBSD-x86-177.80.tar.gz.
===> Patching for nvidia-driver-177.80
===> Applying FreeBSD patches for nvidia-driver-177.80
===> nvidia-driver-177.80 depends on shared library: X11.6 - found
===> nvidia-driver-177.80 depends on shared library: m.3 - found
===> nvidia-driver-177.80 depends on shared library: GL.1 - found
===> Configuring for nvidia-driver-177.80
===> Building for nvidia-driver-177.80
===> src (all)
@ -> /usr/src/sys
machine -> /usr/src/sys/i386/include
awk -f @/tools/makeobjops.awk @/kern/device_if.m -h
awk -f @/tools/makeobjops.awk @/kern/bus_if.m -h
awk -f @/tools/makeobjops.awk @/dev/pci/pci_if.m -h
awk -f @/tools/vnode_if.awk @/kern/vnode_if.src -p
awk -f @/tools/vnode_if.awk @/kern/vnode_if.src -q
awk -f @/tools/vnode_if.awk @/kern/vnode_if.src -h
cc -O2 -pipe -fno-strict-aliasing -DNV_VERSION_STRING=\"177.80\" -D__KERNEL__ -DNVRM -UDEBUG -U_DEBUG -DNDEBUG -O -Werror -D_KERNEL -DKLD_MODULE -nostdinc -I/src -I. -I@ -I@/contrib/altq -finline-limit=8000 --param inline-unit-growth=100 --param large-function-growth=1000 -fno-common -mno-align-long-strings -mpreferred-stack-boundary=2 -mno-mmx -mno-3dnow -mno-sse -mno-sse2 -mno-sse3 -ffreestanding -fstack-protector -std=iso9899:1999 -fstack-protector -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Winline -Wcast-qual -Wundef -Wno-pointer-sign -fformat-extensions -c nvidia_ctl.c
cc -O2 -pipe -fno-strict-aliasing -DNV_VERSION_STRING=\"177.80\" -D__KERNEL__ -DNVRM -UDEBUG -U_DEBUG -DNDEBUG -O -Werror -D_KERNEL -DKLD_MODULE -nostdinc -I/src -I. -I@ -I@/contrib/altq -finline-limit=8000 --param inline-unit-growth=100 --param large-function-growth=1000 -fno-common -mno-align-long-strings -mpreferred-stack-boundary=2 -mno-mmx -mno-3dnow -mno-sse -mno-sse2 -mno-sse3 -ffreestanding -fstack-protector -std=iso9899:1999 -fstack-protector -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Winline -Wcast-qual -Wundef -Wno-pointer-sign -fformat-extensions -c nvidia_dev.c
nvidia_dev.c: In function 'nvidia_dev_open':
nvidia_dev.c:43: error: invalid operands to binary &
nvidia_dev.c: In function 'nvidia_dev_close':
nvidia_dev.c:68: error: invalid operands to binary &
nvidia_dev.c: In function 'nvidia_dev_ioctl':
nvidia_dev.c:91: error: invalid operands to binary &
nvidia_dev.c: In function 'nvidia_dev_poll':
nvidia_dev.c:115: error: invalid operands to binary &
nvidia_dev.c: In function 'nvidia_dev_mmap':
nvidia_dev.c:149: error: invalid operands to binary &
*** Error code 1
Stop in /usr/ports/x11/nvidia-driver/work/NVIDIA-FreeBSD-x86-177.80/src.
*** Error code 1
Stop in /usr/ports/x11/nvidia-driver/work/NVIDIA-FreeBSD-x86-177.80.
*** Error code 1
Stop in /usr/ports/x11/nvidia-driver.
*** Error code 1
Stop in /usr/ports/x11/nvidia-driver.
-------------------------------------------------------------

Obviously there is something wrong with nvidia_dev.c, perhaps a header file has to adapt on newest current or xorg?

Let me know, if I can send more information or test something.
Any help is appreciated.

Many thanks,
Rainer Hurling
rhurlin is offline   Reply With Quote