View Single Post
Old 03-01-09, 05:53 PM   #5
vbtalent
Registered User
 
Join Date: Mar 2009
Posts: 6
Default Re: DVI -> HDMI no sound.. how to resolve?

Thanks for the post Rich.

I've done exactly that but with some mixed results when using just a regular xorg.conf with my dektop LCD I can launch for instance Rythmbo and it boots fast and works fine. With my custom EDID the same application locks up my machine so something must be wrong?

I used the application at http://analogbit.com/node/23 to modify the edid.bin other than that I just modified the xorg.conf I'll post in case you might see something.

Quote:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Tue Jan 27 12:47:59 PST 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
Vendorname "Samsung"
Modelname "LN-T4665F"
Horizsync 30.0-70.0
Vertrefresh 59.0-71.0
modeline "1920x1080" 148.500 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
modeline "1280x720" 74.250 1280 1390 1430 1650 720 725 730 750 +hsync +vsync
modeline "720x480" 27.000 720 736 798 858 480 489 495 525 -hsync -vsync
Gamma 1.0
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
#This should point to the FIXED edid file as described on that webpage after fixing the edid file should
#be 128 bytes. Fix filename and path below accordingly.
Option "CustomEDID" "DFP-0:/etc/X11/edid_mod.bin"
Option "ModeValidation" "AllowNon60HzDFPModes, NoVESAModes, NoXServerModes
Option "ExactModeTimingsDVI" "true"
Option "DPI" "100x100"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
Defaultdepth 24
Option "UdeEDID" "False"
Option "RenderAccel" "true"
Option "DynamicTwinView" "False"
Option "TVOverScan" "0.00000"
Option "AllowGLXWithComposite" "true"
Option "NoLogo"
Option "XvmcUsesTextures" "false"
Option "UseEvents" "True"
Option "ConnectedMonitor" "DFP"
SubSection "Display"
Depth 24
Modes "1920x1080" "1280x720" "720x480"
EndSubSection
EndSection
vbtalent is offline   Reply With Quote