View Single Post
Old 03-10-09, 07:10 PM   #7
zebdits
Registered User
 
Join Date: Mar 2007
Posts: 51
Default Re: status of linux games support

Quote:
Originally Posted by arundel View Post
i installed 180.37 a few minutes ago. what happens when i try to run quake4 is that i get the following error message:

Code:
ERROR: SDL_GL_LoadLibrary libGL.so.1 failed: Failed loading libGL.so.1: /usr/local/lib/libGL.so.1: ELF file OS ABI invalid
Quote:
Originally Posted by arundel View Post
when i run quake4 again i get this error message:

Code:
--------------- R_InitOpenGL ----------------
Initializing SDL subsystem
Loading GL driver 'libGL.so.1' through SDL
signal caught: Segmentation fault
si_code 1
Trying to exit gracefully..
--------------- BSE Shutdown ----------------
---------------------------------------------
WARNING: rvServerScanGUI::Clear() - invalid scanGUI

idRenderSystem::Shutdown()

^CKilled: 9
These same problems was fixed by a friend of mine and described in this pr more than an year ago
http://www.freebsd.org/cgi/query-pr.cgi?pr=118230
Unfortunately no one is taking care about that pr.
The fix worked for me too.
I also have linux-doom3, linux-enemyterritory (+ various mods), and rtcw.
None of the above required the manual fix.
And IMO they work better then in windows (way stable and faster) and linux (little faster+better audio)!
zebdits is offline   Reply With Quote