View Single Post
Old 03-13-09, 04:02 PM   #1
cleanrock
Registered User
 
Join Date: Feb 2009
Posts: 32
Default vdpau fails - 180.37 - MPlayer SVN-r28942-4.3.3

Hi,
I use the following command :
mplayer -v -vo vdpau -vc ffh264vdpau -cache 2000 testfile.mkv &> mplayer.log


I run this same file and command on two computers with same nvidia driver (180.37) and
mplayer (r28942).

This works fine on my computer with a 9600GT 512MB connected to DVI 1680x1050.

It fails on my computer with a 9500GT 512MB connected to HDMI 1920x1080 with the the following messages that i think is relevant (full log attached) :
Code:
...
[vdpau] Error when calling vdp_video_surface_create: An invalid handle value was provided.
...
[vdpau] Error when calling vdp_video_surface_destroy: An invalid handle value was provided.
[vdpau] Error when calling vdp_video_mixer_destroy: An invalid handle value was provided.
[vdpau] Error when calling vdp_presentation_queue_destroy: An invalid handle value was provided.
[vdpau] Error when calling vdp_presentation_queue_target_destroy: An invalid handle value was provided.
[vdpau] Error when calling vdp_output_surface_destroy: An invalid handle value was provided.
[vdpau] Error when calling vdp_output_surface_destroy: An invalid handle value was provided.
[vdpau] Error when calling vdp_output_surface_destroy: An invalid handle value was provided.
[vdpau] Error when calling vdp_device_destroy: An invalid handle value was provided.
vo: uninit ...
In a similar thread here someone thought these errors may because of to little memory. My guess is it is related to HDMI output.
Attached Files
File Type: zip mplayer.log.zip (13.4 KB, 107 views)
cleanrock is offline   Reply With Quote