View Single Post
Old 03-24-09, 05:10 PM   #10
dk75
Registered User
 
Join Date: Jan 2009
Posts: 171
Default Re: Kernel Mode Setting?

Quote:
Originally Posted by davelaser View Post
Besides I think there are more important things the nvidia devs could be working on right now than a pretty boot menu (same goes for the open source devs actually).

I think it's disgraceful that even now it's STILL impossible on any driver with any configuration to get proper synced video while compositing is turned on. It's doing my head in having to switch back to metacity every time I want to watch a video
No need to disable Compiz... here's Nautilus script:
Code:
#!/bin/bash
gksudo xhost +; sudo xinit -e `/usr/bin/mplayer -vc ffh264vdpau -vo vdpau -softvol -ass -vf-clr -fs -fontconfig -overlapsub -subfont-autoscale 1 -embeddedfonts -ffactor 10 "$1"` -- :1 -config "/etc/X11/xorg.conf-vdpau" -depth 24 -ac -nolisten tcp -a 2 &
DISPLAY=:1 /usr/bin/nvidia-settings --config=/home/user/.nvidia-settings-rc-vdpau --ctrl-display=:1 --load-config-only
make "/etc/X11/xorg.conf-vdpau" by "cp" your actual "xorg.conf" and add at the end:
Code:
Section "Extensions"
	Option		"Composite"	"Disable"
EndSection
Also
Code:
cp $HOME/.nvidia-settings-rc $HOME/.nvidia-settings-rc-vdpau
and change string "0/" to "1/" in every line inside ".nvidia-settings-rc-vdpau".
Of course you must have "VBlank" set for XVideo and OpenGL.
__________________
  • Linux Debian Sid x86_64/ 3.2.0
  • Lenovo T61p
  • NVIDIA driver 295.33
  • Xorg/XServer 7.6+12/1.11.4
  • GNOME 3.2.2
dk75 is offline   Reply With Quote