View Single Post
Old 04-01-09, 04:31 AM   #1
eike23
Registered User
 
Join Date: Apr 2009
Posts: 4
Default Triplehead config problem - one monitor stays black

Hey there,

I've searched a lot around this forum and other sources, but could not find anything helpful. If someone had an idea or a good guide that would be appreciated.

My Setup: 2x graphiccard (quadro fx 3400+quadro fx 3500) with 3 monitors (tft, 20") attached to 2x fx3500 and 1x fx3400) on linux ubuntu 8.04. All cards, monitors, cables are ok (switched primary card in bios, changed monitors).

I want to have all three monitors together in X as one display. I DON'T want high performance, 3d, compiz or other stuff, I have to work with it and only need some terminals, editors and rdesktops.

What I did: Install the nvidia driver, run nvidia-xconfig, then nvidia-settings. I select all three displays as own screens (no twinview since I have 3 monitors) and use Xinerama (checkbox in nvidia-settings). I save the config (no merge to have a clean config) and restart X, but the third screen (attached to the fx3400) stays black.

Althrough X sees both cards and all three monitors, it only processes the first two screens.
No Error and no warning, it's just ignored!

When I run nvidia-settings again, the third monitor is again disabled (see screenshot).

I have no more ideas. I've tried setup with twinview plus one screen, with different displays, changed the position and panning - no change.

I've attached the logs+config (bug report), does anyone have an idea? The setup worked on my old system, so there must be a way! As I said, I do not want any glx or high performance, just my three monitors!

Thanks and best regards
Eike
Attached Thumbnails
Click image for larger version

Name:	nvidia-settings.jpg
Views:	155
Size:	63.0 KB
ID:	36302  
Attached Files
File Type: gz nvidia-bug-report.log.gz (30.7 KB, 96 views)
eike23 is offline   Reply With Quote