View Single Post
Old 09-17-03, 09:14 PM   #1
digital
Registered User
 
Join Date: Sep 2003
Posts: 5
Default 2.6.0-test5, minion.de patch, module loads fine, x fails?

I recently began using the 2.6.0-test5 kernel on my workstation. I followed the guide to patch and build the nvidia driver as describe using the minion.de patch. It loads fine but still X is failing.

(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

But it's there? which is odd.

blackbox root # lsmod
Module Size Used by
nvidia 1702508 0
hid 23808 0
uhci_hcd 31624 0
usbcore 68768 2 hid,uhci_hcd
e100 60804 0

Anyone have any ideas what could be causing the problems? I would think if I had a kernel problem it wouldn't load or build fine, which it does.

Maybe my XF86Config is not setup right (works for previous driver version on 2.4.20)?

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
# FontPath "unix/:7100"
EndSection

Section "Module"
# Load "dbe"
# Load "extmod"
# Load "fbdevhw"
Load "glx"
# Load "record"
#Load "freetype"
#Load "type1"
#Load "dri"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "FCT1905"
DisplaySize 390 290
HorizSync 30.0 - 80.0
VertRefresh 56.0 - 60.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce FX (generic)"
VideoRam 131072
Option "NvAgp" "3"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1600x1200" "1400x1050" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
digital is offline   Reply With Quote