View Single Post
Old 04-02-09, 01:37 PM   #4
quorthon
Registered User
 
Join Date: Apr 2009
Posts: 4
Default Re: Problems installing Nvidia Driver on Ubuntu 8.10

Quote:
Originally Posted by twoborg View Post
Do you have the kernel headers installed? (linux-headers-generic)
yes they are installed...

I've tried the following:
- Install the recommend 177 driver with envyng
- Install the driver with System>Administration>Hardware Drivers

With both variants I get the following error at startup:
Code:
NVIDIA(0): Failed to load the NVIDIA kernel module!
And then I have just the 800x600 resolution.

When I try to install the drivers from nvidia I still get the following error:
Code:
ERROR: If you are using a Linux 2.4 kernel, please make sure
       you either have configured kernel sources matching your
       kernel or the correct set of kernel headers installed
       on your system.
       
       If you are using a Linux 2.6 kernel, please make sure
       you have configured kernel sources matching your kernel
       installed on your system. If you specified a separate
       output directory using either the "KBUILD_OUTPUT" or
       the "O" KBUILD parameter, make sure to specify this
       directory with the SYSOUT environment variable or with
       the equivalent nvidia-installer command line option.
       
       Depending on where and how the kernel sources (or the
       kernel headers) were installed, you may need to specify
       their location with the SYSSRC environment variable or
       the equivalent nvidia-installer command line option.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.
I've also tried the steps mentioned here:
http://nvnews.net/vbulletin/showthread.php?t=72490

and here:
https://help.ubuntu.com/community/NvidiaManual

Always the same error...

Here's my xconf.org:
Code:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
	DefaultDepth	24
EndSection

Section "Module"
	Load "glx"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
	Driver	"nvidia"
	Option	"NoLogo"	"True"
EndSection
Is there any other way to solve my problem?

Thanks for your help.
Peter
quorthon is offline   Reply With Quote