View Single Post
Old 04-02-09, 01:45 PM   #1
mbobak
Registered User
 
Join Date: Jan 2009
Posts: 32
Default X won't start w/ best available resolution...

Hi,

I'm running:
Ubuntu 8.10
NVidia driver 180.29
XFX 9500 GT
Pioneer Elite PRO-151FD Plasma Display (1080p)
Connection from 9500GT to TV is DVI to HDMI

Whenever I restart X, it insists on starting up X in 1024x768 mode. But, if I go to nvidia-settings, I have no problem at all selecting 1920x1080. So, if it's capable of that mode, how do I get it to *start* X in that mode??

In my /etc/X11/xorg.conf, I have:
Option "metamodes" "nvidia-auto-select +0+0; 1920x1080 +0+0"

One (failed) suggestion was to reverse the position of the auto-select and 1920x1080 in the line above. That doesn't appear to have any effect.

Does anyone have any thoughts or ideas?

Here's the complete /etc/X11/xorg.conf:
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder57)  Thu Mar  5 18:47:52 PST 2009

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder57)  Thu Mar  5 18:48:47 PST 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"

#    RgbPath         "/usr/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "PIONEER-TV"
    HorizSync       15.0 - 69.0
    VertRefresh     23.0 - 61.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9500 GT"
EndSection

Section "Screen"

# Removed Option "metamodes" "1920x1080 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TVStandard" "HD1080p"
    Option         "TwinView" "0"
    Option         "metamodes" "nvidia-auto-select +0+0; 1920x1080 +0+0"
    Option         "TripleBuffer" "true"
    Option         "NoLogo" "false"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection
Thanks in advance for any help or suggestions,

-Mark
mbobak is offline   Reply With Quote