View Single Post
Old 04-03-09, 11:15 AM   #1
aaneiros
Registered User
 
Join Date: Feb 2009
Posts: 15
Default Mplayer vdpau and nvidia 8200 IGP

Hi. I recently bought a jetway motherboard with an onboard nvidia 8200 as I had read it would be capable of displaying 1080P video on my LCD. The motherboard model is NC62K. I am using 2 GBs of memory and an AMD 4850e processor on debian unstable.

I have tried both the mplayer package from debian multimedia (which used to include vdpau support but now it seems not to) and my own compiled mplayer from latest svn version plus the latest nvidia drivers (180.44).

Previously I had tried mplayer-vdpau on my laptop with exciting results (amazing difference in cpu usage). However, on this machine, mplayer uses less cpu when I use -vo xv than when using vdpau.

Anyway, in both cases, I am unable to play practically any 1080P mkv file as cpu usage goes above 99%, video and audio start to go out of synch and mplayer complains my system is too slow.

I expected to be able to play any sort of HD material on this rig so I am wondering if this could be a hardware problem.. maybe the GPU is just not capable enough?

This is whay vdpau prints on my console:

Forced video codec: ffh264vdpau
Forced video codec: ffmpeg12vdpau
Forced video codec: ffvc1vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] Trying pixfmt=0.
Unsupported PixelFormat -1
VDec: vo config request - 1920 x 1080 (preferred colorspace: VC1 VDPAU acceleration)
VDec: using VC1 VDPAU acceleration as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1920x1080 => 1920x1080 VC1 VDPAU acceleration [zoom]
[VD_FFMPEG] XVMC-accelerated MPEG-2.
[VD_FFMPEG] Trying pixfmt=0.
[VD_FFMPEG] XVMC-accelerated MPEG-2.
[vc1_vdpau @ 0x89228a0]Incomplete extradata
Could not open codec.
VDecoder init failed
Forced video codec: ffwmv3vdpau
Opening video decoder: [dmo] DMO video codecs
DMO dll supports VO Optimizations 0 1
DMO dll might use previous sample when requested
Decoder supports the following formats: YV12 YUY2 UYVY YVYU RGB8 RGB555 RGB565 RGB24 RGB32
Decoder is capable of YUV output (flags 0x1b)
VDec: vo config request - 1920 x 1080 (preferred colorspace: Packed YUY2)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1920x1080 => 1920x1080 Planar YV12 [zoom]
Selected video codec: [wmvvc1dmo] vfm: dmo (Windows Media Video (VC-1) Advanced Profile)

and then it informs me that my system is too slow.

Note: I have disabled the composite extension in my xorg.conf.

Regards.
aaneiros is offline   Reply With Quote