View Single Post
Old 04-03-09, 06:46 PM   #1
Registered User
Join Date: Apr 2009
Posts: 3
Default Unusable 3D acceleration after Fedora 10 upgrade

I am hoping someone may have knowledge that I have not be able to locate anywhere else on the web. I have recently upgraded from Fedora 9 to 10. Prior to the upgrade I had decent 3D rendering using a 2.6.26... rev. kernel and the proprietary nVidia drivers from RPMFusion version 173.xx. It was enough to enjoy Second Life much of the time. 3D applications (including Second Life) will run now, but at a very low frame rate. I have used the Unigine Tropics demo for testing and in the more complex/detailed renderings I get about 5 fps. I have also noted my CPU temp climbs now while attempting 3D rendering whereas it did not before.

I am currently on a kernel rev. and nVidia drivers 180.29. I have verified no errors in my Xorg log and that it shows the following excerpt:
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Setting mode
(II) NVIDIA(0): "CRT-0:nvidia-auto-select+1680+0,CRT-1:nvidia-auto-select+0+0"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
I have also verified that direct rendering is enabled by using:
$ glxinfo | grep direct
direct rendering: Yes
I have read through the nVidia documentation and verified that I have no stale simlinks and also used ldd to verify the correct, nVidia libs are loaded for glxgears.
$ ldd /usr/bin/glxgears => (0x0022f000) => /usr/lib/nvidia/ (0x033a9000) => /lib/ (0x005fb000) => /lib/ (0x00485000) => /usr/lib/ (0x007b5000) => /usr/lib/nvidia/ (0x04f1d000) => /usr/lib/nvidia/tls/ (0x00ceb000) => /usr/lib/ (0x008f0000) => /lib/ (0x00626000)
/lib/ (0x0045c000) => /usr/lib/ (0x007b1000) => /usr/lib/ (0x008b8000) => /usr/lib/ (0x008de000) => /usr/lib/ (0x008d6000)
My xorg.conf is fairly simple:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder63) Thu Feb 5 00:19:09 PST 2009

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules/extensions"
ModulePath "/usr/lib/xorg/modules/fonts"
ModulePath "/usr/lib/xorg/modules/multimedia"
ModulePath "/usr/lib/xorg/modules"

Section "ServerFlags"
Option "AIGLX" "on"
Option "Xinerama" "0"

Section "InputDevice"
# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "Monitor"
Identifier "Monitor0"
VendorName "LG"
ModelName "LG W2252"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7600 GT"

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "NoLogo" "1"
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "CRT-0: nvidia-auto-select +1680+0, CRT-1: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24

Section "Extensions"
Option "Composite" "Enable"
I am quite stumped and would appreciate any insight someone might have.
Proc: Mobile AMD Athlon XP-M 2800+
Graphics: GeForce 7600 GT
Mem: 2 Gb
Dist: Fedora 10
nVidia Drv: 180.29 (RPMFusion)
dragontome is offline   Reply With Quote