View Single Post
Old 04-06-09, 07:29 PM   #1
okreylos
Registered User
 
Join Date: Jan 2009
Posts: 7
Unhappy 280 GTX / 180.44 low OpenGL performance?

Hi,

I just put together a new computer (Intel i7 2.67 GHz, 6GB RAM, 280 GTX, Fedora 10 x86_64) and was expecting a significant OpenGL performance increase compared to the old one (Intel Xeon 3.6 GHz, 2GB RAM, 8800 GTX, Fedora 8 x86_64).

CPU-wise, the new computer is at least 2x faster in every application. With OpenGL, however, I got nuthin'.

I'm developing / running a visualization app that creates very large triangle meshes using vertex buffer objects and indexed triangle sets, and when creating a mesh of ~2M triangles, I get ~21fps on the old computer. On the new computer, I get -- guess what -- 21 fps.

On top of that, I initially got significant stutter for about 20 seconds, right after uploading the mesh into the vbo on the new computer, but then applied the nopat kernel option as suggested here, and now the stutter is barely noticeable, but still there.

On the old computer, I'm running driver 173.14.12, on the new one 180.44.

I've heard everywhere that the 280 GTX beats the stuffing out of the 8800 GTX -- have I been lied to? Have the Nvidia developers successfully throttled OpenGL performance in the 180.* driver series to force people to spend more money on new graphics cards? Am I doing something wrong? What's going on?

Does anybody have any insight? Are there any Xorg configuration options I should try? Apart from the disappointing performance and the (now barely noticeable) stutter, things are working fine.
okreylos is offline   Reply With Quote