View Single Post
Old 04-08-09, 09:48 PM   #1
ignus
Registered User
 
Join Date: Apr 2009
Posts: 2
Default Shader problem 180.44

I just started with this thing of shaders...

I'm using xubuntu 8.10 (2.6.27-11-generic) 8600M GT. When trying to compile some opengl code that I had.. I got errors, I checked glxinfo and somehow my 3d rendering was disabled. I looked in the nvidia driver page and I downloaded the last one. My opengl application was running correctly.

Then I started programming the shader and got this:

0(6) : error C1115: unable to find compatible overloaded function "normalize(error)"
0(7) : error C1115: unable to find compatible overloaded function "normalize(error)"
0(8) : error C1115: unable to find compatible overloaded function "reflect(vec3, error)"

And so on...

I'm very new in this subject.. so any help would be appreciated. I just need to know why this is not working (I read somewhere that this has to do with the pixel shader.. that I should use the version 2, but I've no idea how to do that)... So thanks!
ignus is offline   Reply With Quote