View Single Post
Old 04-10-09, 07:57 PM   #21
jyavenard
MythTV developer
 
Join Date: Mar 2006
Posts: 413
Default Re: Floating point exception with > 180.29

Quote:
Originally Posted by twistedfall View Post
I'm running Gentoo on x86 and with recent NVIDIA driver versions I started to experience SIGFPE with some apps. For example:

$ mplayer
Floating point exception
$ amarok
Floating point exception
$ firefox
Floating point exception

This bug started in 180.35 and still present in 180.37 and 185.13. Downgrading to 180.29 resolves this problem. The culprit is libGL.so. Replacing it with version 180.29 also solves this problem.

Switching to xorg-x11 opengl implementation removes the problem too (as NVIDIA libGL.so is no longer used in this case)

I tried rebuilding all apps that have opengl use-flag, but that didn't help.

I can confirm that it is definitely the case.

Spent several hours tracking a segfault in mythmusic ..

Issue always ended up in libGL.so ...
And as there's no debugging symbol in there ; I can't say what's going on ...

drivers 180.44.
Tested on both Ubuntu 8.10 (2.6.27-11) and 9.04 (2.6.28-11).
32 bits
jyavenard is offline   Reply With Quote