View Single Post
Old 04-19-09, 09:50 AM   #1
oldcpu
Linux Neophyte
 
Join Date: Sep 2004
Posts: 14
Default Desktop Video corruption & VDPAU playback freeze w/180.44 and 185.19 on 8400GS

This post is intended to be a bug report (I hope this is the correct forum for it) on the 180.44 driver and 185.19 driver. Please delete thread if this is not appropriate location.

Problem:

On openSUSE-11.1 with KDE-3.5.10 desktop with BFG 8400GS PCI 256MB (not PCI-e) card on 9 year old Athlon-1100 (1GB RAM) , with both 180.44 driver and 185.19 driver, obtain the same anomalous behaviour.
  • The behaviour on the desktop is corruption in the openSUSE desktop theme (KDE classic theme lasts many minutes longer before corruption - but still occurs) , especially if large icons are chosen on desktop, but still occurs with small icons. Corruption is also icon independant. Example screen shot: http://img218.imageshack.us/img218/4...th18519scr.jpg
    Problem does not occur when using VESA driver
  • the VDPAU anomalous behaviour is a freeze of the video after a short period of playing the video under the Packman packaged mplayer MPlayer-1.0rc2_r29116-2.pm.2 This occurs playing HD Videos and also playing DVD compliant MPEG files created by application tovid tovid-0.40-2777.pm.svn20081205_1 (which uses mencoder and ffmpeg). Playing mpeg files back with mplayer without vdpau option works fine. (Of course HD definition videos do not play back without vdpau)
Examples of vdpau error messages:
Code:
lee@stonehenge01:~/computer/camcorder/test/h264clips> mplayer -vo vdpau -vc ffh264vdpau Serenity\ -\ HD\ DVD\ Trailer.mp4
MPlayer dev-SVN-r29116-4.3-openSUSE Linux 11.1 (i686)-Packman (C) 2000-2009 MPla
yer TeamCan't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing Serenity - HD DVD Trailer.mp4.
libavformat file format detected.
[lavf] Video stream found, -vid 0
[lavf] Audio stream found, -aid 1
VIDEO:  [avc1]  1280x720  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
Clip info:
 name: Serenity - HD DVD Trailer
 author: Universal Pictures
==========================================================================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] XVMC-accelerated MPEG-2.
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
FAAD: compressed input bitrate missing, assuming 128kbit/s!
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[VD_FFMPEG] XVMC-accelerated MPEG-2.
VDec: vo config request - 1280 x 720 (preferred colorspace: H.264 VDPAU accelera
tion)
VDec: using H.264 VDPAU acceleration as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [vdpau] 1280x720 => 1280x720 H.264 VDPAU acceleration
[vdpau] Error when calling vdp_presentation_queue_block_until_surface_idle: The
display was pre-empted, or a fatal error occurred.
[vdpau] Error when calling vdp_video_mixer_render: An invalid handle value was provided.
[vdpau] Error when calling vdp_presentation_queue_display: An invalid handle value was provided.
[vdpau] Failed VDPAU decoder rendering: An invalid handle value was provided.
[vdpau] Error when calling vdp_presentation_queue_block_until_surface_idle: An invalid handle value was provided.
[vdpau] Error when calling vdp_video_mixer_render: An invalid handle value was provided.
[vdpau] Error when calling vdp_presentation_queue_display: An invalid handle value was provided.
[vdpau] Failed VDPAU decoder rendering: An invalid handle value was provided.
[vdpau] Error when calling vdp_presentation_queue_block_until_surface_idle: An invalid handle value was provided.
[vdpau] Error when calling vdp_video_mixer_render: An invalid handle value was provided.
[vdpau] Error when calling vdp_presentation_queue_display: An invalid handle value was provided.
[vdpau] Failed VDPAU decoder rendering: An invalid handle value was provided.
Some notes - the Athlon-1100 PC in which this runs has a 350 watt original power supply, and is 9 years old. The BFG 8400GS card requires a 300 watt power supply. I assume the power supply is still adequate after 9 years. I note same problem with desktop graphic corruption does not occur with VESA driver hence giving me faith in power supply. There is no evidence of over heating in the PC, as fans are clean and functioning well.

Attached are nvidia-bug-report.log files from both 180.44 and 185.19 occurrences of the problem on this same PC.
Attached Files
File Type: gz nvidia-bug-report.log-185.19.gz (46.2 KB, 90 views)
File Type: gz nvidia-bug-report-180.44.log.tar.gz (39.1 KB, 86 views)
oldcpu is offline   Reply With Quote