View Single Post
Old 04-20-09, 01:39 AM   #24
shaoxuan
Registered User
 
shaoxuan's Avatar
 
Join Date: Jun 2007
Location: Beijing, China
Posts: 14
Send a message via ICQ to shaoxuan Send a message via MSN to shaoxuan
Default Re: Can't enable Desktop Effect after upgrading to snv_111

Quote:
Originally Posted by paulgress View Post
OK, were going to try again. If you look at the post on this link:

http://www.opensolaris.org/jive/thre...start=0#368315

They show the error message they are getting:

"Error message: /usr/bin/compiz-bin (core) - Fatal: Root visual is not
a GL visual
/usr/bin/compiz-bin (core) - Error: Failed to manage screen: 0
/usr/bin/compiz-bin (core) - Fatal: No manageable screens found on
display :0.0"

It looks identical to yours. The only difference is they started it with the command "compiz-bin, it's basically the same, compiz is a shell script to start "compiz-bin". So we established you have the same problem, so you should require the same solution.

At the root prompt enter:

# svccfg -s application/opengl/ogl-select setprop options/vendor=nvidia
# svcadm restart application/opengl/ogl-select

This time I discovered an error with the previous post. The word application doesn't end with an "s". If you look at the previous posts there was an "s" showing as "applications". So just copy and paste the above entry and you should be good.
Hello Paulgress,

amazing! now the Desktop Effect works, Thanks Paul, I have wasted you too much time.
shaoxuan is offline   Reply With Quote