View Single Post
Old 04-23-09, 08:26 AM   #27
kernelOfTruth
Gentoo Linux addict
 
Join Date: Nov 2007
Location: Vienna, Austria; Germany; hello world :)
Posts: 202
Default Re: Floating point exception with > 180.29

safe cflags/cxxflags/ldflags aren't necessarily needed

the only "triggers" so far (at least for me) seem to be:

*) cairo compiled with glitz-support

*) pie-support (which is included in the new gcc ?)

fstack-protector-all and -D_FORTIFY_SOURCE=2 seem to be fine

(I can't tell for sure)
__________________
2.6.30-rc3-zen0+ w. compcache, reiser4 + ccreg40 (lzo-compression + checksumming)
gcc version 4.4.0-pre9999 built 20090425 (prerelease) rev. 146764 (Gentoo SVN)
gcc version 4.4.0 (Gentoo Hardened 4.4.0-r1, espf-0.2.1)
Ubuntu Jaunty/9.04 x86_64 Dell XPS M1330
kernelOfTruth is offline   Reply With Quote