View Single Post
Old 04-28-09, 11:53 AM   #40
Quantumstate
Registered User
 
Join Date: May 2008
Posts: 166
Default Re: Video Haltiness Multiple Times/Second

Yeah, in compiling my (lib improved) mythtv-fixes.20445 it hauls ass through libavformat, libavutil, and libavcodec, but when it gets to libmythsoundtouch:
Code:
 ccache g++ -c -pipe -g -march=k8 -fomit-frame-pointer -O3 -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -D__STDC_CONSTANT_MACROS -I/usr/include/kde/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -fPIC -DPIC -w -D_REENTRANT  -DMMX -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/share/qt3/mkspecs/default -I. -I../../../../../include -I../../../../../../include -I../../libs/libavcodec -I../.. -I../../../../../../include/qt3 -o cpu_detect_x86_gcc.o cpu_detect_x86_gcc.cpp
ccache g++ -c -pipe -g -march=k8 -fomit-frame-pointer -O3 -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -D__STDC_CONSTANT_MACROS -I/usr/include/kde/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -fPIC -DPIC -w -D_REENTRANT  -DMMX -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/share/qt3/mkspecs/default -I. -I../../../../../include -I../../../../../../include -I../../libs/libavcodec -I../.. -I../../../../../../include/qt3 -o mmx_gcc.o mmx_gcc.cpp
mmx_gcc.cpp: In member function ‘virtual long int soundtouch::TDStretchMMX::calcCrossCorrStereo(const short int*, const short int*) const’:
mmx_gcc.cpp:89: error: ‘mmx_t’ was not declared in this scope
mmx_gcc.cpp:89: error: ‘pv1’ was not declared in this scope
mmx_gcc.cpp:89: error: expected primary-expression before ‘)’ token
mmx_gcc.cpp:89: error: expected `;' before ‘pV1’
mmx_gcc.cpp:94: error: ‘mm1’ was not declared in this scope
mmx_gcc.cpp:94: error: ‘movq_a2r’ was not declared in this scope
mmx_gcc.cpp:95: error: ‘mm2’ was not declared in this scope
mmx_gcc.cpp:97: error: ‘mm5’ was not declared in this scope
mmx_gcc.cpp:97: error: ‘movd_v2r’ was not declared in this scope
mmx_gcc.cpp:103: error: ‘pv2’ was not declared in this scope
mmx_gcc.cpp:103: error: ‘pmaddwd_a2r’ was not declared in this scope
mmx_gcc.cpp:104: error: ‘mm3’ was not declared in this scope
mmx_gcc.cpp:106: error: ‘mm4’ was not declared in this scope
mmx_gcc.cpp:122: error: ‘pv2’ was not declared in this scope
mmx_gcc.cpp:122: error: ‘pmaddwd_a2r’ was not declared in this scope
... etc
I wonder if I can disable soundtouch? Nah, it's probably integral to sound speed control.

I tried disabling mmx just to get through, but same error. Probably just needs some sort of #include statement. But I'd never figure it out; I'm a real estate developer, not a coder.

Here is my procedure:
- svn checkout svn://svn.ffmpeg.org/ffmpeg/trunk ffmpeg
- Delete mythtv/libs subdirectories: libavcodec, libavformat and libavutil
- Copy ffmpeg subdirectories: libavcodec, libavformat and libavutil into mythtv/libs
- Copy ffmpeg files: common.mak, config.mak, and subdir.mak into mythtv/libs
- ln -s mythtv/libs/libavcodec/x86 mythtv/libs/libavcodec/i386
- ./configure --enable-proc-opt --enable-vdpau --enable-xvmc-opengl --enable-opengl-video --enable-opengl-vsync --disable-xvmcw --disable-directfb --disable-joystick-menu --disable-ivtv --disable-firewire --disable-dbox2 --disable-hdhomerun --disable-audio-oss
- make -j 4
Quantumstate is offline   Reply With Quote