View Single Post
Old 05-01-09, 04:37 PM   #2
sillyeagle
sillyego
 
sillyeagle's Avatar
 
Join Date: Sep 2005
Location: USA
Posts: 5,394
Default Re: FSX Studders no matter what..

I'm sure you would be more likely to get a response in the FSX thread, but I also had stutters with i7 and Win7. There's several work arounds.

1) Lock the framerate in-game. (comes with performance hit)

2) Lock the framerate with a 3rd party app like FPS_Limter. (no performance hit)

3) Set a Buffer Pool via the cfg to an extremely high value like 100-300MB. (needs lots of vram)

With only 512MB of video RAM you may only be able to get away with a 100MB Buffer Pool, but the higher you can go the better off you will be.

Also FSX responds best if you disable Hyperthreading as it may have issues with thread collisions due to faux threads being spawned. FSX does not support HT. With HT disabled set an Affinity Mask of 15 in cfg.

This is what I use with Autogen set to Extremely Dense and framerate set to unlimted, which is totally stutter free. The Buffer Pool is the magic tweak, and without that I must use a framerate lock at a value I can consistently achieve to eliminate the stutters.

[DISPLAY]
TEXTURE_BANDWIDTH_MULT=110

[TERRAIN]
TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=2400
TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=1600

[BUFFERPOOLS]
PoolSize=300000000

[JOBSCHEDULER]
AffinityMask=15

__________________
Intel Core i7 920 Nehalem Quad @ 4.0GHz
EVGA GTX 660 SLI @ 1046MHz
OCZ Platinum CL7 6GB
EVGA Intel X58
_____________
A man's dreams are an index to his greatness.
sillyeagle is offline   Reply With Quote