View Single Post
Old 05-04-09, 05:16 AM   #4
jui
Registered User
 
Join Date: May 2009
Posts: 4
Default Re: [Bug Report] KDE4 Plasma looses theming and fonts with 180.44/180.51/185.19

I didn't noticed anything special using xrestop after and before QPainter crash bottom bar:

Before:
xrestop - Display: localhost:0
Monitoring 53 clients. XErrors: 0
Pixmaps: 82719K total, Other: 171K total, All: 82891K total

res-base Wins GCs Fnts Pxms Misc Pxm mem Other Total PID Identifier
5200000 22 11 0 373 449 14508K 11K 14520K 32466 Qt-subapplication
1600000 129 2 0 356 836 12435K 22K 12458K 4520 kwin
4600000 0 22 0 35 32 7458K 1K 7459K ? <unknown>
6400000 0 22 0 25 21 7225K 1K 7226K ? <unknown>
5600000 8 5 0 210 266 4095K 6K 4101K 30957 Krusader
2e00000 8 2 0 135 200 3011K 4K 3016K 31475 CZ-Tunes - Silent Service II :: Amarok 2
1200000 6 2 0 51 79 200K 2K 202K 4744 kupdateapplet
5400000 3 1 0 48 61 170K 1K 171K 29984 kdesu
0800000 7 1 0 24 47 154K 1K 155K 4584 kmix
1800000 5 1 0 129 173 149K 4K 153K 4561 Qt-subapplication

After:
xrestop - Display: localhost:0
Monitoring 50 clients. XErrors: 0
Pixmaps: 107149K total, Other: 226K total, All: 107376K total

res-base Wins GCs Fnts Pxms Misc Pxm mem Other Total PID Identifier
5200000 24 14 0 2855 2958 28273K 70K 28343K 29957 Qt-subapplication
1600000 121 2 0 357 823 26840K 22K 26863K 4520 kwin
4600000 0 22 0 35 32 7458K 1K 7459K ? <unknown>
6400000 0 22 0 25 21 7225K 1K 7226K ? <unknown>
5600000 8 5 0 210 266 4095K 6K 4101K 30957 Krusader
2e00000 8 2 0 135 197 3011K 4K 3016K 31475 CZ-Tunes - Silent Service II :: Amarok 2
1200000 6 2 0 51 78 200K 2K 202K 4744 kupdateapplet
5400000 3 1 0 48 61 170K 1K 171K 29984 kdesu
0800000 7 1 0 24 46 154K 1K 155K 4584 kmix
1800000 5 1 0 129 171 149K 4K 153K 4561 Qt-subapplication

It's happen randomly. 3-5 hours all is ok, and suddenly bottom bar (task manager) disappear or stop working properly and I get loop message:

QPainter::setCompositionMode: Painter not active
QPainter::end: Painter not active, aborted
QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setCompositionMode: Painter not active
QPainter::end: Painter not active, aborted
QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setCompositionMode: Painter not active
QPainter::end: Painter not active, aborted
QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setCompositionMode: Painter not active
QPainter::end: Painter not active, aborted
QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setCompositionMode: Painter not active
QPainter::end: Painter not active, aborted
QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setCompositionMode: Painter not active

I have tried reinstall KDE, install different QT versions - no results.
jui is offline   Reply With Quote