View Single Post
Old 05-06-09, 11:04 AM   #12
wck555
Registered User
 
Join Date: Apr 2009
Posts: 9
Default Re: Problems with audio over HDMI on Apple TV

Quote:
Originally Posted by toor View Post
I'm not exactly sure, but by modifying EDID in some way we can make HDMI audio to work. But I may be wrong.
Anyway, until we know how nvidia driver decides whether to disable HDMI audio, all we can do is guessing.
I thought about this. But my TV already reports that it can handle audio in the EDID data. Below is an excerpt from my TV's EDID parsed by "Monitor Asset Manager" - a windows program
Code:
CE audio data (formats supported)
  LPCM    2-channel, 16/20/24 bit depths at 32/44/48 kHz

CE speaker allocation data
  Channel configuration.... 2.0
  Front left/right......... Yes
  Front LFE................ No
  Front center............. No
  Rear left/right.......... No
  Rear center.............. No
  Front left/right center.. No
  Rear left/right center... No
  Rear LFE................. No
So I don't know what else I could add to the EDID data that would make the nvidia driver enable audio.

On another note, several people have reported that they can re-enable HDMI audio by dropping out of X and then reloading alsa. This does not work for me. Once the nvidia driver has loaded I have to reboot to re-enable HDMI audio. Does dropping out of X and reloading alsa work for you? If so what version of alsa, nvidia driver, and linux are you running? I am running Ubuntu 8.10 with alsa 1.0.19.
wck555 is offline   Reply With Quote