View Single Post
Old 05-08-09, 12:34 AM   #5
SIl0x0000
Registered User
 
Join Date: May 2009
Posts: 4
Default Re: Not able to run Xorg 1.5.3 on a GeForce 9300M (in an EMS64T) using driver ver 180

Quote:
Originally Posted by AaronP View Post
The fundamental problem here is that your X server cannot find any PCI devices. Please run "ldd /usr/bin/Xorg" and verify that it's linked against libpciaccess. If it's not, I suspect it somehow got compiled with PCI support disabled and I would recommend recompiling it and making sure that it finds libpciaccess correctly.
Its seems that Xorg uses the libpciaccess library with version 0.10.5. I'm going to search on the Xorg site for more information on this. I've to work now...

ldd output printed below
Code:
# ldd /usr/bin/Xorg
/usr/bin/ldd: line 161: /lib/ld-linux.so.2: cannot execute binary file
        linux-vdso.so.1 =>  (0x00007fff259ff000)
        libpciaccess.so.0 => /usr/lib/libpciaccess.so.0 (0x00007f721d5b4000)
        libdl.so.2 => /lib/libdl.so.2 (0x00007f721d3b0000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x00007f721d195000)
        libXfont.so.1 => /usr/lib/libXfont.so.1 (0x00007f721cf59000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007f721ccc8000)
        libbz2.so.1 => /lib/libbz2.so.1 (0x00007f721cab8000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x00007f721c8b5000)
        libfontenc.so.1 => /usr/lib/libfontenc.so.1 (0x00007f721c6ae000)
        libz.so.1 => /lib/libz.so.1 (0x00007f721c499000)
        libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x00007f721c256000)
        libhal.so.1 => /usr/lib/libhal.so.1 (0x00007f721c045000)
        libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0x00007f721be0a000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007f721bc04000)
        libcrypto.so.0.9.8 => /usr/lib/libcrypto.so.0.9.8 (0x00007f721b88a000)
        libm.so.6 => /lib/libm.so.6 (0x00007f721b609000)
        librt.so.1 => /lib/librt.so.1 (0x00007f721b400000)
        libc.so.6 => /lib/libc.so.6 (0x00007f721b0b7000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f721d7bb000)
I also recompiled libpciacces, no difference (i included the build log in an attachment) for the sake of being complete /lib64 is accessible through a symbolic link /lib

thanx again
Attached Files
File Type: gz libpciaccess.txt.gz (4.8 KB, 85 views)
SIl0x0000 is offline   Reply With Quote