View Single Post
Old 05-11-09, 03:01 PM   #1
dhylton
Registered User
 
Join Date: Mar 2005
Posts: 3
Unhappy dual external monitors attached to docking station - please help

let me start out by stating that this configuration worked previously using ubuntu 8.04. i just upgraded to 9.04 and neither the supplied drivers nor the latest official (180.51) work with the original configuration with or without tweaks. i'm basically giving up and hoping for some help. here is what i have:

compaq 8710p laptop with quadro nvs 320m (g84) with 1680x1050 display,
connected to hp docking station providing dvi and vga output.
i have two identical hp l1940t flat panel monitors, 1280x1024@60 native;
one is directly connected to the dvi port on the docking station,
one is connected to docking station vga port via kvm switch.

my goal is to use both monitors simultaneously (laptop lid closed, no need for built-in display). the nvidia driver seems to be mapping the displays as follows:
DFP-0 : laptop display
DFP-1 : external dvi
CRT-0 : external vga

on bootup, DFP-1 is the active screen. as soon as X starts, that goes black and CRT-0 becomes the display. in most cases, DFP-1 is not detected at all; the only way i've been able to utilize it is to force with ConnectedMonitor and UseDisplayDevice options. the best resolution i've seen appears to be 640x480 or so; any attempt at forcing the mode to 1280x1024 or 1024x768 results in the monitor turning itself off and the desktop being confined to CRT-0 (which can be made to use 1280x1024).

i'll attach the originally-working xorg.conf (from ubuntu 8.04) as well as the current config. currently CRT-0 is 1280x1024 and DFP-1 appears to be 640x480. both are quite ugly as i hacked quite a bit to get the end result.

any help / hand-holding / whatever that gets me to the goal would be_greatly_ appreciated!
Attached Files
File Type: txt xorg.conf.804.txt (5.5 KB, 91 views)
File Type: txt xorg.conf.txt (2.9 KB, 95 views)
File Type: gz nvidia-bug-report.log.gz (37.6 KB, 78 views)
dhylton is offline   Reply With Quote