View Single Post
Old 09-24-03, 04:08 AM   #1
kenmc
Registered User
 
Join Date: Sep 2003
Location: Currently Eindhoven, NL
Posts: 3
Default How to enable TvOut on RH9/Asus Geforce4 440MX

Hi,
I've spent the last few days playing with my XF86Config to try and enable TV output on my Asus V9180 Video Suite (http://www.asus.com/products/vga/v9180vs/overview.htm). I've read loads of posts here on how to enable twinview etc, but still have not managed to get it working.
here's an extract from my XF86Config
------------- begin-----------------
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 MX (generic)"
VideoRam 65536
Option "TwinView" "1"
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorVertRefresh" "60"
Option "MetaModes" "1024x768 @1024x768,800x600 @800x600;800x600 @800x600,800x600 @800x600;640x480 @640x480,640x480 @640x480"
#Option "ConnectedMonitor" "DFP, TV"
Option "TVStandard" "PAL-B"
Option "TVOutFormat" "COMPOSITE"
Option "TwinViewOrientation" "Clone"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
---------------end -------------------
(The MedaModes line will probably wrap here - it's really all in one line!)

If I uncomment the line
Option "ConnectedMonitor" "DFP, TV"
I get nothing whatsoever - the monitor receives no signal, and neither does the tv. As it is above, commented, then I get monitor output again
Some specs:
Athlon 2600XP
AOpen AK77-8XN mobo
512 MB Ram
Asus V9180 Geforce4 440MX graphics
Monitor : Philips 150 B3 Flatscreen monitor
Attempting to connect to the TV via a composite cable - this works fine in Windoze 2k.

From the logfile: If I enable the "ConnectedMonitor" line above I get the following :
(WW) NVIDIA(0): Failure reading EDID parameters for display device TV-0
(WW) NVIDIA(0): Failure reading EDID parameters for display device DFP-0

but if i disable that line leaving everything else as-is I get this:
(WW) NVIDIA(0): Only one display device connected; disabling TwinView.
(WW) NVIDIA(0): The user specified VertRefresh "40.000-70.000" has been
(WW) NVIDIA(0): adjusted to "56.000-70.000" (the intersection with
(WW) NVIDIA(0): EDID-specified VertRefresh "56.000-76.000"

(and yes - the nvidia driver is being loaded :
(II) LoadModule: "nvidia"
)


Another question I have is how is it possible to switch from the monitor to the TV - in windoze I have the option of setting up a hotkey to switch from one to the other. Is this possible, or is it just that both are on always? If this is the case how will this affect video grab from the TV???

Any help that can be provided will be much appreciated....
Cheers
Ken
kenmc is offline   Reply With Quote