View Single Post
Old 05-22-09, 11:39 AM   #2
mschifter
Registered User
 
Join Date: May 2009
Posts: 2
Default Re: Trouble with 8300 GS driving 2 very different monitors

I should've posted my settings before. Here's Xorg.conf:

Section "Files"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "on"
EndSection

Section "Module"
Load "freetype"
Load "dbe"
Load "dri"
Load "glx"
Load "extmod"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "microsoftpro"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "Monterey International USB Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Option "CalcAlgorithm" "XServerPool"
DisplaySize 340 270
HorizSync 31-83
Identifier "Monitor[0]"
ModelName "2208WFP(Analog)"
Option "PreferredMode" "1680x1050"
VendorName "DELL"
VertRefresh 56-75
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "GeForce 8300 GS"
Driver "nvidia"
Identifier "Device[0]"
Option "NoLogo"
Option "SaXDualHead"
Option "TwinView"
Option "SaXDualMonitorVendor" "--> LCD"
Option "SaXDualOrientation" "RightOf"
Option "MetaModes" "1680x1050,640x480;1600x1024,640x480;1600x1000,640 x480;1400x1050,640x480;1600x900,640x480;1280x1024, 640x480;1440x900,640x480;1280x960,640x480;1366x768 ,640x480;1360x768,640x480;1280x800,640x480;1152x86 4,640x480;1280x768,640x480;1280x720,640x480;1024x7 68,640x480;1280x600,640x480;1024x600,640x480;800x6 00,640x480;768x576,640x480;640x480,640x480"
Option "SaXDualResolution" "640x480"
Option "TwinViewOrientation" "RightOf"
Option "SaXDualMode" "Xinerama"
Option "SecondMonitorVertRefresh" "50-61"
Option "SaXDualHSync" "30-50"
Option "SaXDualMonitorModel" "640X480@60HZ"
Option "SaXDualVSync" "50-61"
Screen 0
VendorName "NVidia"
EndSection

Here it's obvious the previous section sets up the 640x480 display. But getting it running in multiheaded mode is another matter... This is the same physical setup as on the other 8300 GS machine running under Windows XP Pro...and works. Under Linux/SaX2/OpenSUSE 11.1, exploring any activated multi-headed mode with the "tester" does not work on the second monitor, and also nothing shows up under a multiboot situation.

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection


Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
Option "Composite" "on"
EndSection
mschifter is offline   Reply With Quote