View Single Post
Old 09-24-03, 05:27 AM   #3
C4mper
Registered User
 
Join Date: Sep 2003
Posts: 4
Send a message via ICQ to C4mper
Default

Originally posted by SuLinUX
> Where did you run that file from as you need to use the one that came from suse update.

My file NVIDIA-Linux-x86-1.0-4496.pkg2.run comes from nvidia download page. My kernel sources come from SuseUpdate, sure!

> Start suse in safe mode, login as root and type cd /usr/share/doc/nvidia
Running in safe mode is clear due to not running X. Root is clear. In that given directory is NVIDIA_GLX1.0, nothing else...
[QOUTE]
Then type:
./NVIDIA-Linux-x86-1.0-4496.pkg2.run [/quote]
I?ve never done anything else, but not from that directory above, which should not make any difference at all.

I would like to post my /var/log/nvidia-installer.log, but that seems to be quite long and finishs with :
...
Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
4496). As part of installing this driver (version: 1.0-4496), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Kernel include path: '/lib/modules/2.4.20-4GB-athlon/build/include'
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f nv.o os-agp.o os-interface.o os-registry.o nv-linux.o nv_compiler.h *
.d NVdriver nvidia.o
-> Building kernel module:
executing: 'cd ./usr/src/nv; make nvidia.o SYSINCLUDE=/lib/modules/2.4.20-4G
B-athlon/build/include'...
You appear to be compiling the NVIDIA kernel module with
a compiler different from the one that was used to compile
the running kernel. This may be perfectly fine, but there
are cases where this can lead to unexpected behaviour and
system crashes.
If you know what you are doing and want to override this check, you can do so by setting IGNORE_CC_MISMATCH.

In any other case, set the CC environment variable to the
name of the compiler that was used to compile the kernel.

*** Failed cc sanity check. Bailing out! ***
make: *** [gcc-check] Error 1
-> Error.
...
So i have set IGNORE_CC_MISMATCH=yes and it runs fine by compiling a new kernel interface for 2.4.20-4GB. But then he mismatches with my running kernel as I wrote in the title.
How should I set the CC environment variable to the name of the compiler? What compiler has SuSE used?

Thanky for help, but I suppose the solution above does not seem to be one.

Philipp


Quote:
Then just reboot. [/b]
Yeah, good old windows times. Just reboot
__________________
NVidia Geforce4 4200Ti
AMD Athlon
Suse Linux 8.2
Kernel 2.4.20-4GB-athlon

Last edited by C4mper; 09-24-03 at 05:35 AM.
C4mper is offline   Reply With Quote