View Single Post
Old 06-03-09, 10:34 AM   #82
ScottKnight
Registered User
 
Join Date: Jan 2009
Location: Allison Park, PA, USA, Earth
Posts: 13
Default Re: VDPAU testing tool

Wow, my 9300 really can be a 9400 Here is a pretty much as-assembled Asus P5N7A-VM (integrated 9300) with E7200. iGPU is at 450/1200:
Code:
Intel(R) Core(TM)2 Duo CPU     E7200  @ 2.53GHz
NVIDIA GPU GeForce 9300 / nForce 730i (C79) at PCI:3:0:0

VDPAU API version : 0
VDPAU implementation : NVIDIA VDPAU Driver Shared Library  185.18.14  Wed May 27 01:54:36 PDT 2009

SURFACE GET BITS: 909.213 M/s
SURFACE PUT BITS: 990.007 M/s

MPEG DECODING (1920x1080): 60 frames/s
MPEG DECODING (1280x720): 136 frames/s
H264 DECODING (1920x1080): 53 frames/s
H264 DECODING (1280x720): 112 frames/s
VC1 DECODING (1440x1080): 67 frames/s

MIXER WEAVE (1920x1080): 303 frames/s
MIXER BOB (1920x1080): 428 fields/s
MIXER TEMPORAL (1920x1080): 109 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 145 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 33 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 36 fields/s

MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 126 fields/s
And simply setting the clock speeds on the iGPU to 9400 specs (580/1400):
Code:
Intel(R) Core(TM)2 Duo CPU     E7200  @ 2.53GHz
NVIDIA GPU GeForce 9300 / nForce 730i (C79) at PCI:3:0:0

VDPAU API version : 0
VDPAU implementation : NVIDIA VDPAU Driver Shared Library  185.18.14  Wed May 27 01:54:36 PDT 2009

SURFACE GET BITS: 911.728 M/s
SURFACE PUT BITS: 997.498 M/s

MPEG DECODING (1920x1080): 77 frames/s
MPEG DECODING (1280x720): 175 frames/s
H264 DECODING (1920x1080): 67 frames/s
H264 DECODING (1280x720): 144 frames/s
VC1 DECODING (1440x1080): 85 frames/s

MIXER WEAVE (1920x1080): 365 frames/s
MIXER BOB (1920x1080): 528 fields/s
MIXER TEMPORAL (1920x1080): 126 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 169 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 40 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 43 fields/s

MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 152 fields/s
Now I have true HD capability with HDMI audio in a nearly dead-silent setup...that only draws ~37w at idle. Life is pretty good. Thanks for the testing tool crisalide. Thanks for the sweet hardware and driver development Nvidia.

Edit: Just for snicks, I pushed it around a little. Setting the iGPU speeds to 750/1600 with +100mV, it booted just fine, but I couldn't see the mouse cursor and the menus were flaky in Gnome. Bumping down to 745/1600 with +100mV (with a little screen corruption during the mpeg test):
Code:
VIDIA GPU GeForce 9300 / nForce 730i (C79) at PCI:3:0:0

VDPAU API version : 0
VDPAU implementation : NVIDIA VDPAU Driver Shared Library  185.18.14  Wed May 27 01:54:36 PDT 2009

SURFACE GET BITS: 1075.33 M/s
SURFACE PUT BITS: 1201.06 M/s

MPEG DECODING (1920x1080): 99 frames/s
MPEG DECODING (1280x720): 224 frames/s
H264 DECODING (1920x1080): 86 frames/s
H264 DECODING (1280x720): 177 frames/s
VC1 DECODING (1440x1080): 101 frames/s

MIXER WEAVE (1920x1080): 72464 frames/s
MIXER BOB (1920x1080): 163180 fields/s
MIXER TEMPORAL (1920x1080): 25040 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 43848 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 22448 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 36492 fields/s

MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 22056 fields/s
Not so sure I can trust those deinterlacing results anymore. From 600 through 720MHz, everything scaled quite proportionally. The most amazing thing is that the GPU core temp only went up from 38 at the stock settings to 41 at the highest. Color me impressed with this system.
__________________
Scott Knight

Last edited by ScottKnight; 06-08-09 at 09:36 PM. Reason: Added 745 MHz result
ScottKnight is offline   Reply With Quote