View Single Post
Old 06-04-09, 03:30 AM   #3
gurucubano
Registered User
 
Join Date: Jun 2009
Location: Munich
Posts: 7
Default Re: X 1.6 && 180.60 && Xinerama: crashes with sig 11 after some time

Quote:
Originally Posted by kpapaxristou View Post
Hello,

I'm running 8-CURRENT and I use the 180.60 driver too. Xorg seems to have no problems. Relating to xinerama I have this in my logs:

$ grep -i xinera /var/log/Xorg.0.log
(II) Loading extension XINERAMA
(II) Initializing built-in extension XINERAMA

Still I have seen no crashes.

Also is it possible for you to try and compile the vdpinfo utility which links with the nvidia-vdpau libs ? I think there is some trouble there too.

If you need me to run any more tests, please tell me.
Hello,

If I do the same grep I will get:

$ grep -i xinera /var/log/Xorg.0.log
(**) Option "Xinerama" "1"
(**) Xinerama: enabled
(**) NVIDIA(1): Option "TwinViewXineramaInfoOrder" "CRT-0"
(II) Initializing built-in extension XINERAMA

Are you really using the Xinerama with a second display? The crashes only occure if I have a second display attached or after having plug'ed off this display but the Xinerama view is still active. When I restart Xorg after this without changing anything in the xorg.conf file, there is no crash at all.

This morning I have updated (i.e. switched back) to version 180.44 which is in -CURRENT in the /usr/ports; same crash after nearly one hour this time.

Concerning the mentioned tool 'vdpinfo', what do you want me to do with this? Is this somekind of test tool?

Thanks for your feedback in any case.

Matthias
gurucubano is offline   Reply With Quote