View Single Post
Old 06-09-09, 11:02 AM   #7
reno31
Registered User
 
Join Date: Jun 2009
Posts: 4
Default Re: Error when calling vdp_device_create_x11

Done, i modified the config file of mplayer.

but That dont do a lot of things

Code:
mplayer -v -vo vdpau -vc ffmpeg12vdpau MPEGIO3MBPS30sec.mpg
MPlayer SVN-r29318-4.3.3 (C) 2000-2009 MPlayer Team                                             
CPU vendor name: AuthenticAMD  max cpuid level: 5                                               
CPU: AMD Athlon(tm) 7750 Dual-Core Processor (Family: 16, Model: 2, Stepping: 3)                
extended cpuid-level: 26                                                                        
extended cache-info: 33587520                                                                   
Detected cache-line size is 64 bytes                                                            
Testing OS support for SSE... yes.                                                              
Tests of OS support for SSE passed.                                                             
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNowExt: 1 SSE: 1 SSE2: 1 SSSE3: 0                          
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowExt SSE SSE2 CMOV                     
get_path('codecs.conf') -> '/home/renaud/.mplayer/codecs.conf'                                  
Reading /home/renaud/.mplayer/codecs.conf: Can't open '/home/renaud/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory                                                                                                                    
Using built-in default codecs.conf.                                                                                  
Configuration:                                                                                                       
CommandLine: '-v' '-vo' 'vdpau' '-vc' 'ffmpeg12vdpau' 'MPEGIO3MBPS30sec.mpg'                                         
init_freetype                                                                                                        
get_path('font/font.desc') -> '/home/renaud/.mplayer/font/font.desc'                                                 
font: can't open file: /home/renaud/.mplayer/font/font.desc                                                          
font: can't open file: /usr/local/share/mplayer/font/font.desc                                                       
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay                                                             
get_path('fonts') -> '/home/renaud/.mplayer/fonts'                                                                   
Using nanosleep() timing                                                                                             
get_path('input.conf') -> '/home/renaud/.mplayer/input.conf'                                                         
Can't open input config file /home/renaud/.mplayer/input.conf: No such file or directory                             
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory                            
Falling back on default (hardcoded) input config                                                                     
Setting up LIRC support...                                                                                           
get_path('MPEGIO3MBPS30sec.mpg.conf') -> '/home/renaud/.mplayer/MPEGIO3MBPS30sec.mpg.conf'                           

Playing MPEGIO3MBPS30sec.mpg.
get_path('sub/') -> '/home/renaud/.mplayer/sub/'
[file] File size is 12353536 bytes              
STREAM: [file] MPEGIO3MBPS30sec.mpg             
STREAM: Description: File                       
STREAM: Author: Albeu                           
STREAM: Comment: based on the code from ??? (probably Arpi)
LAVF_check: MPEG-PS format                                 
Checking for YUV4MPEG2                                     
ASF_check: not ASF guid!                                   
Checking for REAL                                          
Checking for SMJPEG                                        
Searching demuxer type for filename MPEGIO3MBPS30sec.mpg ext: .mpg
Checking for Nullsoft Streaming Video                             
Checking for MOV                                                  
Checking for VIVO                                                 
header block 1 size: 0                                            
AVS: avs_check_file - attempting to open file MPEGIO3MBPS30sec.mpg
AVS: File is too big, aborting...                                 
Checking for PVA                                                  
Checking for MPEG-TS...                                           
TRIED UP TO POSITION 68484, FOUND 47, packet_size= 0, SEEMS A TS? 0
Checking for LMLM4 Stream Format                                   
Invalid packet in LMLM4 stream: ch=0 size=1140851704               
LMLM4 Stream Format not found                                      
system stream synced at 0xD (13)!                                  
==> Found video stream: 0                                          
==> Found audio stream: 0                                          
MPEG-PS file format detected.                                      
Searching for sequence header... OK!                               
VIDEO:  MPEG2  704x576  (aspect 2)  25.000 fps  3000.0 kbps (375.0 kbyte/s)
[V] filefmt:2  fourcc:0x10000002  size:704x576  fps:25.000  ftime:=0.0400  
get_path('sub/') -> '/home/renaud/.mplayer/sub/'                           
X11 opening display: :0.0                                                  
vo: X11 color mask:  FFFFFF  (R:FF0000 G:FF00 B:FF)                        
vo: X11 running at 3200x1080 with depth 24 and 32 bpp (":0.0" => local display)
[x11] Detected wm supports NetWM.                                              
[x11] Detected wm supports FULLSCREEN state.                                   
[x11] Detected wm supports ABOVE state.                                        
[x11] Detected wm supports BELOW state.                                        
[x11] Detected wm supports STAYS_ON_TOP state.                                 
[x11] Current fstype setting honours FULLSCREEN STAYS_ON_TOP ABOVE BELOW X atoms
==========================================================================      
Forced video codec: ffmpeg12vdpau                                               
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family                
Unsupported PixelFormat -1                                                      
INFO: libavcodec init OK!                                                       
Selected video codec: [ffmpeg12vdpau] vfm: ffmpeg (FFmpeg MPEG-1/2 (VDPAU))     
==========================================================================      
==========================================================================      
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3                           
dec_audio: Allocating 4608 + 65536 = 70144 bytes for output buffer.             
mp3lib: using 3DNow!Ex optimized decore!                                        
MP3lib: init layer2&3 finished, tables done                                     
MPEG 1.0, Layer II, 48000 Hz 128 kbit Stereo, BPF: 384                          
Channels: 2, copyright: No, original: No, CRC: No, emphasis: 0                  
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)           
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)          
==========================================================================      
Building audio filter chain for 48000Hz/2ch/s16le -> 0Hz/0ch/??...              
[libaf] Adding filter dummy                                                     
[dummy] Was reinitialized: 48000Hz/2ch/s16le                                    
[dummy] Was reinitialized: 48000Hz/2ch/s16le                                    
Trying every known audio driver...                                              
ao2: 48000 Hz  2 chans  s16le                                                   
audio_setup: using '/dev/dsp' dsp device                                        
audio_setup: using '/dev/mixer' mixer device                                    
audio_setup: using 'pcm' mixer device                                           
audio_setup: sample format: s16le (requested: s16le)                            
audio_setup: using 2 channels (requested: 2)                                    
audio_setup: using 48000 Hz samplerate (requested: 48000)                       
audio_setup: frags:  16/16  (4096 bytes/frag)  free:  65536                     
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)                                
AO: Description: OSS/ioctl audio output                                         
AO: Author: A'rpi                                                               
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...       
[dummy] Was reinitialized: 48000Hz/2ch/s16le                                    
[dummy] Was reinitialized: 48000Hz/2ch/s16le                                    
Starting playback...                                                            
Increasing filtered audio buffer size from 0 to 65536                           
[VD_FFMPEG] XVMC-accelerated MPEG-2.                                            
[ffmpeg] aspect_ratio: 1.333333                                                 
VDec: vo config request - 704 x 576 (preferred colorspace: MPEG2 VDPAU acceleration)
Trying filter chain: vo                                                             
VDec: using MPEG2 VDPAU acceleration as output csp (no 1)                           
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.                        
VO Config (704x576->768x576,flags=0,'MPlayer',0x1DC80002)                           
VO: [vdpau] 704x576 => 768x576 MPEG2 VDPAU acceleration                             
VO: Description: VDPAU with X11                                                     
VO: Author: Rajib Mahapatra <rmahapatra@nvidia.com> and others                      
VDPAU nvidia: Error detected 1026 58  5                                             
VDPAU nvidia: Backtrace:                                                            
--: /usr/lib/libvdpau_nvidia.so [0xb52e6000] DSO load base                          
00: /usr/lib/libvdpau_nvidia.so [0xb52eae69]                                        
01: /usr/lib/libvdpau_nvidia.so [0xb5334511]
02: /usr/lib/libvdpau_nvidia.so [0xb530a65c]
03: /usr/lib/libvdpau_nvidia.so [0xb53027a5]
04: /usr/lib/libvdpau_nvidia.so [0xb52f1c30]
VDPAU nvidia: Error detected 1026 58  5
VDPAU nvidia: Backtrace:
--: /usr/lib/libvdpau_nvidia.so [0xb52e6000] DSO load base
00: /usr/lib/libvdpau_nvidia.so [0xb52eae69]
01: /usr/lib/libvdpau_nvidia.so [0xb5334511]
02: /usr/lib/libvdpau_nvidia.so [0xb530a65c]
03: /usr/lib/libvdpau_nvidia.so [0xb53027a5]
04: /usr/lib/libvdpau_nvidia.so [0xb52f1c30]
VDPAU nvidia: Error detected 0 2604
VDPAU nvidia: Backtrace:
--: /usr/lib/libvdpau_nvidia.so [0xb52e6000] DSO load base
00: /usr/lib/libvdpau_nvidia.so [0xb52ea0a9]
01: /usr/lib/libvdpau_nvidia.so [0xb52f1cc6]
[vdpau] Failed creating VDPAU decoder: A catch-all error, used when no other error code applies.
FATAL: Cannot initialize video driver.
[mpegvideo_vdpau @ 0x899b2c0]get_buffer() failed (-1 0 0 (nil))
Error while decoding frame!

FATAL: Could not initialize video filters (-vf) or video output (-vo).

Uninit audio filters...
[libaf] Removing filter dummy
Uninit audio: mp3lib
Uninit video: ffmpeg
vo: uninit ...

Exiting... (End of file)
Another Attachment log provide with the export VDPAU_NVIDIA_DEBUG=3
Attached Files
File Type: gz nvidia-bug-report.log.gz (40.3 KB, 93 views)
reno31 is offline   Reply With Quote