View Single Post
Old 06-13-09, 10:00 AM   #2
paulgress
Registered User
 
Join Date: Sep 2005
Posts: 38
Default Re: xorg.conf doesn't appear to be read

To answer my own post. Doing research I found that Nvidia will not automatically start its own saved extension available from "nvidia-settings". There are a few ways to achieve this. One way is to add the command "nvidia-settings -l" into the ".xinitrc" file. My computer has multiple links and files so I opted not to use this method. What I decided to do was add that command into my "/home/.profile" file. The "-l" option for "nvidia-settings" just means read and load the ".nvidia-settings-rc" saved using the "nvidia-settings" utility. This worked for me.

One last method, it appears Nvidia/Xorg does read the "xorg.conf" file, its just when saved from the "nvidia-settings" utility, it doesn't add any extensions. You have to add them manually.

Example:

For the cursor shadow to work I had to add following line into /etc/X11/xorg.conf file

Option "CursorShadow" "true"

Also, the "nvidia-settings -l" method above will also get the cursor shadow working.

My take on this, the "nvidia-settings" utility should have a check box to ask if you would like these setting to automatically start at boot by adding its own entry to /home/.profile file or globally by adding it to .xinitrc file.
paulgress is offline   Reply With Quote