View Single Post
Old 06-14-09, 10:38 PM   #11
Sasha_A
Slackware!
 
Join Date: Apr 2008
Location: Nova Scotia
Posts: 18
Default Re: Ethernet not working! (forcedeth)

Code:
alias eth0 forcedeth
options forcedeth optimization_mode=2 msi=1 dma_64bit=1 phy_power_down=0
I have a DHCP server running for the home LAN here, and as of kernel release 2.6.29 there were some changes to the forcedeth driver code, which powered down the NIC during reboots/power off. It caused havoc for many, because the NIC did not power up at next boot.
I couldn't get an IP address without repeatedly restarting the network a bunch of times, and never got an IP during boot, it just hung.

The driver regression was reverted in 2.6.29.3 or .4 but still the default behavior seemed to be to remain powered off.

What I posted above is from my 'forcedeth' file in /etc/modprobe.d folder.
Notice the option "phy_power_down" option! It makes the NIC stay powered up during reboots etc.. Voila! Now it works perfect again, getting its IP from DHCP in a blink of an eye during boot.

You can use either the 'modinfo' command, or look at the bottom of the forcedeth.c sourcecode, for all the parameters you can pass to the driver.

Good luck; hope this helps.

Sasha
Sasha_A is offline   Reply With Quote