View Single Post
Old 07-10-09, 11:59 AM   #4
konst
Registered User
 
Join Date: May 2006
Posts: 57
Default Re: HELP "execution attempt in: /usr/lib64/opengl/nvidia/lib/libGLcore.so.180.60"

Quote:
Originally Posted by AaronP View Post
The GL driver needs to generate code for performance reasons. I'll suggest it as a new feature request, but it's unlikely that we'll be able to provide a special driver specifically for PAX/grsec systems.
By the way, I should add that if the fact that "GL driver needs to generate code for performance reasons" means it's a security risk then nvidia shouldn't be doing it that way and all the drivers you provide should be secure not just for people who use PAX/grsec systems.

You obviously would know about the cards; I use the 8800 GTX. Couldn't the huge processing power of the GPU do the code generation in the card's memory since I'm sure the nvidia libGL wouldn't need much memory for the code it generates?
konst is offline   Reply With Quote