View Single Post
Old 07-13-09, 03:39 PM   #1
jsbid
Registered User
 
Join Date: May 2006
Posts: 8
Default VT-switching works only if no TV is attached, zapping works always

FreeBSD 7.2-STABLE
xorg-server-1.6.1
NO hald or dbus crap
nvidia0: <GeForce 7300 LE> on vgapci0
Nvidia driver: 185.18.14

A DFP is connected to the DVI port of the card.
A TV is connected to the Cinch-Port of the card.

Zapping (Ctrl-Alt-Backspace) works always, the server teminates and drops
to the console.
VT-switching (Ctrl-Alt-Fn) switches to the VT but the cursor is in the upper left
corner and keypresses are ignored. However, by pressing Alt-F8 I can return to
the X session and everything is OK there.

When I start the X-server without the TV being connected, VT-switching works.

I have attached the Xorg.log files for both cases, their diff and the xorg.conf.
I have also played around by loading the int10 module and played with its
options. Nothing changes.

Any idea whats going on here?

Thanks!

diff between both logs:
Code:
--- xorg.log_NOTV       2009-07-13 20:36:50.000000000 +0200
+++ xorg.log_TV 2009-07-13 20:34:29.000000000 +0200
@@ -11,7 +11,7 @@
 Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
-(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul 13 20:34:49 2009
+(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul 13 19:33:58 2009
 (==) Using config file: "/usr/local/lib/X11/xorg.conf"
 (++) ServerLayout "voyager"
 (**) |-->Screen "NV_PCIe_H0-DFP1280" (0)
@@ -162,9 +162,10 @@
 (II) NVIDIA(0): Detected PCI Express Link width: 8X
 (--) NVIDIA(0): Interlaced video modes are supported on this GPU
 (--) NVIDIA(0): Connected display device(s) on GeForce 7300 LE at PCI:7:0:0:
+(--) NVIDIA(0):     NVIDIA TV Encoder (TV-0)
 (--) NVIDIA(0):     FUS P19-2 (DFP-0)
-(--) NVIDIA(0): FUS P19-2 (DFP-0): 165.0 MHz maximum pixel clock
-(--) NVIDIA(0): FUS P19-2 (DFP-0): Internal Single Link TMDS
+(--) NVIDIA(0): NVIDIA TV Encoder (TV-0): 400.0 MHz maximum pixel clock
+(--) NVIDIA(0): TV encoder: NVIDIA
 (II) NVIDIA(0): Assigned Display Device: DFP-0
 (II) NVIDIA(0): Validated modes:
 (II) NVIDIA(0):     "1280x1024"
@@ -194,17 +195,18 @@
 (II) NVIDIA(1): Detected PCI Express Link width: 8X
 (--) NVIDIA(1): Interlaced video modes are supported on this GPU
 (--) NVIDIA(1): Connected display device(s) on GeForce 7300 LE at PCI:7:0:0:
+(--) NVIDIA(1):     NVIDIA TV Encoder (TV-0)
 (--) NVIDIA(1):     FUS P19-2 (DFP-0)
-(--) NVIDIA(1): FUS P19-2 (DFP-0): 165.0 MHz maximum pixel clock
-(--) NVIDIA(1): FUS P19-2 (DFP-0): Internal Single Link TMDS
-(WW) NVIDIA(1): Unable to find any of the requested display device "TV-0" in
-(WW) NVIDIA(1):     the list of available display devices "".
-(EE) NVIDIA(1): Unable to find available Display Devices for screen 1.
-(II) UnloadModule: "nvidia"
-(II) UnloadModule: "wfb"
-(II) UnloadModule: "fb"
+(--) NVIDIA(1): NVIDIA TV Encoder (TV-0): 400.0 MHz maximum pixel clock
+(--) NVIDIA(1): TV encoder: NVIDIA
+(II) NVIDIA(1): Assigned Display Device: TV-0
+(II) NVIDIA(1): Validated modes:
+(II) NVIDIA(1):     "720x576"
+(II) NVIDIA(1): Virtual screen size determined to be 720 x 576
+(==) NVIDIA(1): DPI set to (75, 75); computed from built-in default
+(==) NVIDIA(1): Enabling 32-bit ARGB GLX visuals.
 (--) Depth 24 pixmap format is 32 bpp
-(II) do I need RAC?  No, I don't.
+(II) do I need RAC?  Yes, I do.
 (II) resource ranges after preInit:
        [0] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[b]
        [1] -1  0       0x000c0000 - 0x000effff (0x30000) MX[b]
@@ -224,6 +226,17 @@
 (II) Loading extension NV-CONTROL
 (II) Loading extension XINERAMA
 (==) RandR enabled
+(II) NVIDIA(1): Initialized GPU GART.
+(II) NVIDIA(1): Setting mode "720x576"
+(II) NVIDIA(1): NVIDIA 3D Acceleration Architecture Initialized
+(==) NVIDIA(1): Disabling shared memory pixmaps
+(II) NVIDIA(1): Using the NVIDIA 2D acceleration architecture
+(==) NVIDIA(1): Backing store disabled
+(==) NVIDIA(1): Silken mouse enabled
+(II) NVIDIA(1): DPMS enabled
+(==) RandR enabled
+(II) Entity 0 shares no resources
+(II) Entity 1 shares no resources
 (II) Initializing built-in extension Generic Event Extension
 (II) Initializing built-in extension SHAPE
 (II) Initializing built-in extension MIT-SHM
@@ -274,3 +287,4 @@
 (**) Option "CustomKeycodes" "off"
 (**) Keyboard: CustomKeycodes disabled
 (II) XINPUT: Adding extended input device "Keyboard" (type: KEYBOARD)
Attached Files
File Type: log xorg_TV.log (12.3 KB, 155 views)
File Type: log xorg_NOTV.log (11.8 KB, 149 views)
File Type: txt xorg_log_diff.txt (3.5 KB, 200 views)
File Type: txt xorg_conf.txt (10.5 KB, 169 views)
jsbid is offline   Reply With Quote