View Single Post
Old 08-28-09, 05:50 AM   #6
udippel
Registered User
 
Join Date: Oct 2004
Posts: 42
Default Re: GeForce9600 + Linux = Problems (Resolution issue) | Can't make it higher than 640

Quote:
Originally Posted by frunobulax View Post
So, here it is.

All I did was install the driver and perform nvidia-xconfig --mode=1680x1050.

Right now, I'm at 640X480.
Yes, but you didn't listen. You didn't move the xorg.conf out of the way.

Nevermind, here in your log the problem is obvious:

(--) NVIDIA(0): --- EDID for DFP-0 ---
(--) NVIDIA(0):
(--) NVIDIA(0): No EDID Available.
(--) NVIDIA(0):
(--) NVIDIA(0): --- End of EDID for DFP-0 ---
(--) NVIDIA(0):
(II) NVIDIA(0): Frequency information for DFP-0:
(II) NVIDIA(0): HorizSync : 28.000-33.000 kHz
(II) NVIDIA(0): VertRefresh : 43.000-72.000 Hz
(II) NVIDIA(0): (HorizSync from HorizSync in X Config Monitor section)
(II) NVIDIA(0): (VertRefresh from VertRefresh in X Config Monitor
(II) NVIDIA(0): section)
(II) NVIDIA(0):

Your DFP-0 seems to give out an invalid identifier, Nvidia falls back to standard monitor settings, and there is not much that 28-33 kHz can accommodate; so what you get further down is:

(II) NVIDIA(0): Validating Mode "1680x1050":
(II) NVIDIA(0): 1680 x 1050 @ 60 Hz
(II) NVIDIA(0): Mode Source: X Server
(II) NVIDIA(0): Pixel Clock : 119.00 MHz
(II) NVIDIA(0): HRes, HSyncStart : 1680, 1728
(II) NVIDIA(0): HSyncEnd, HTotal : 1760, 1840
(II) NVIDIA(0): VRes, VSyncStart : 1050, 1053
(II) NVIDIA(0): VSyncEnd, VTotal : 1059, 1080
(II) NVIDIA(0): H/V Polarity : +/-
(WW) NVIDIA(0): Mode is rejected: HorizSync (64.7 kHz) out of range
(WW) NVIDIA(0): (28.000-33.000 kHz).

This means, you need to tell Nvidia that your monitor is much better; by adding something like

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "my flat panel"
HorizSync 30.0 - 68.0
VertRefresh 50.0 - 70.0
Option "DPMS"
EndSection

and then also make it use a mode, like what you do already.
udippel is offline   Reply With Quote