View Single Post
Old 09-10-09, 05:14 PM   #1
Gusar
Registered User
 
Join Date: Apr 2006
Posts: 277
Default Can't set PowerMizer level via RegistryDwords on drivers newer than 180.60

Yeah, another PowerMizer rant...

With all drivers up to and inclusive 180.60, I had this in xorg.conf:
Code:
Option "RegistryDwords" "PerfLevelSrc=0x2222; PowerMizerLevelAC=0x3; PowerMizerLevel=0x3"
to force the graphic card (Geforce Go 6600) into the lowest performance mode. With drivers newer than 180.60, this option doesn't work anymore and the card goes into PerfLevel 2 (the highest) as soon as X starts.

The reason this is an issue is that the graphic card is broken. If X even starts properly (mostly I get a black screen or some vertical lines), very soon the picture turns into this: http://img17.imageshack.us/img17/8833/screenshot01l.png and usually X then locks up. Forcing the card into the lowest performance level would make things work.
Why this is an issue even further is that the 180.60 driver doesn't compile with 2.6.31 kernel, so I'm stuck at 2.6.30 forever.

I tried settings RegistryDwords by passing it to the kernel module instead of specifying it in xorg.conf. Works with 180.60, doesn't work with newer drivers.


My question is: Why was the ability to set the PerfLevel via the RegistryDwords option removed? Is there any other way to set it?
Gusar is offline   Reply With Quote