View Single Post
Old 09-19-09, 12:02 AM   #8
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: VDPAU Error: DISPLAY PRE-EMPTED

There are some XIDs in your logs:

Code:
[  136.779739] NVRM: Xid (0002:00): 6, PE0003 
[  150.690877] NVRM: Xid (0002:00): 6, PE0001 
[  333.730543] NVRM: Xid (0002:00): 13, 0001 00000000 0000502d 000008c4 f7eef822 00000004
[  333.732653] NVRM: Xid (0002:00): 13, 0001 00000000 0000502d 000008c4 f7eef822 00000004
[  430.696771] NVRM: Xid (0002:00): 6, PE0003 
[  432.524399] NVRM: Xid (0002:00): 13, 0001 00000000 00005097 00001414 05ab05d7 0000000c
[  434.488196] NVRM: Xid (0002:00): 13, 0001 00000000 00005097 000015e0 41000000 0000000c
Given the varied nature of the XID messages, and the fact that the problem doesn't reproduce at any particular spot in any particular clip, my first inclination is some kind of general system instability. If you run heavy OpenGL applications, do you see additional XID messages in your logs (dmesg)? OpenGL can recover from some of these errors, so you might not notice simply by watching the application's rendering.

Finally, VDPAU can experience "display preemption" for a variety of reasons, such as the GPU experiencing certain kinds of errors when processing commands (which is what appears to be happening for you), VT-switches, and X mode (resolution etc.) switches, or certain internal inconsistent state in the VDPAU driver or similar errors.
Stephen Warren is offline   Reply With Quote