View Single Post
Old 09-24-09, 09:08 PM   #1
sangu
Registered User
 
Join Date: Feb 2005
Posts: 84
Default 190.36 beta driver build error in Fedora rawhide kernel 2.6.31.

Quote:
mod-190.36/_kmod_build_2.6.31-33.fc12.x86_64/usr/src/nv/Module.markers -w -s
WARNING: could not find /home/sangu/rpmbuild/BUILD/nvidia-kmod-190.36/_kmod_build_2.6.31-33.fc12.x86_64/usr/src/nv/.nv-kernel.o.cmd for /home/sangu/rpmbuild/BUILD/nvidia-kmod-190.36/_kmod_build_2.6.31-33.fc12.x86_64/usr/src/nv/nv-kernel.o
FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol 'lockdep_init_map'
make[3]: *** [__modpost] Error 1
make[2]: *** [modules] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
Building 185.18.36 driver works well in kernel 2.6.31.

Last edited by sangu; 04-22-11 at 09:15 PM.
sangu is offline   Reply With Quote